Gracias Gracias:  0
Resultados 1 al 1 de 1

Tema: Compilar blender en debian testing wheezy

  1. #1
    Senior Member Avatar de ofuscado
    Fecha de ingreso
    Apr 2009
    Mensajes
    177

    Blender Compilar blender en debian testing wheezy

    Tutorial compilar la última versión de blender en debían ( wheezy testing ):

    DEPENDENCIAS:
    sudo aptitude install subversión build-essential gettext \
    libxi-dev libsndfile1-dev \
    libpng12-dev libfftw3-dev \
    libopenexr-dev libopenjpeg-dev \
    libopenal-dev libalut-dev libvorbis-dev \
    libglu1-mesa-dev libsdl1.2-dev libfreetype6-dev \
    libtiff4-dev libavdevice-dev \
    libavformat-dev libavutil-dev libavcodec-dev libjack-dev \
    libswscale-dev libx264-dev libmp3lame-dev python3.2-dev \
    libspnav-dev

    echo "ssl-trust-default-ca = no" >> ~/.subversión/servers

    cd ~
    mkdir blender-svn
    cd blender-svn
    svn co https://svn.blender.org/svnroot/bf-b.../trunk/blender
    svn up

    <platform> en mi caso = linux64

    cd ~/blender-svn
    svn co https://svn.blender.org/svnroot/bf-blender/trunk/lib/<platform> lib/<platform>
    svn up

    Si nuestro pc es monocore:
    cd ~/blender-svn/blender
    python scons/scons.py

    Si tienes un dual core:
    cd ~/blender-svn/blender
    python scons/scons.py -j 2

    Si tienes un quad core:
    cd ~/blender-svn/blender
    python scons/scons.py -j 8

    1º problema:

    blablabla
    Using config file: build_files/scons/config/linux-config.py #<-- nos dice el archivo de config que esta usando.
    blablabla

    Missing: "/usr/include/python3.2m/Python.h",
    Set 'BF_PYTHON_INC' to point to a valid python include path.
    Containing Python.h for python versión "3.2"

    Solución 1º problema:

    Miramos si tenemos un "mu" o "m"
    ls /usr/include/python3.2mu en mi caso muy entonces:

    Editar el build_files/scons/config/linux-config.py (en mi caso tal y como explico entre los 2 blablabla)
    esto:
    BF_PYTHON_ABI_FLAGS = 'm'
    por:
    BF_PYTHON_ABI_FLAGS = 'mu'

    cd ~/blender-svn/blender
    ln -s ../install/linux/blender ./blender

    Ya podemos ejecutarlo:
    ./blender

    Para actualizarlo una vez ya compilado:
    cd ~/blender-svn/blender ; svn up ; python scons/scons.py -j 8

    Fuentes originales:
    http://wiki.blender.org/index.php/De...c_Distro/Scons
    Última edición por ofuscado; 28-11-2011 a las 15:07

Temas similares

  1. Blender Compilar Blender en Windows
    Por Freemind en el foro Blender
    Respuestas: 0
    Último mensaje: 26-05-2012, 20:43
  2. Blender Intentando compilar blender
    Por MMalkavian en el foro Problemas con Programas
    Respuestas: 10
    Último mensaje: 27-10-2009, 17:43
  3. Problema Compilar Blender
    Por fog en el foro Todo menos Infografía
    Respuestas: 13
    Último mensaje: 08-03-2008, 22:17
  4. Compilar Blender: no encuentra dxguid lib
    Por Troler en el foro Problemas con Programas
    Respuestas: 5
    Último mensaje: 26-12-2007, 14:52
  5. Compilar Blender
    Por vleda en el foro Infografía General
    Respuestas: 5
    Último mensaje: 12-05-2007, 09:01

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •