Resultados 1 al 1 de 1

Tema: Instalar juntos YafRay 0 1 1 y YafRay dt-420 versión en desarrollo

  1. #1
    Nivel Héroe Avatar de povmaniaco
    Fecha de ingreso
    Nov 2008
    Ubicación
    Barcelona
    Mensajes
    711
    Gracias (Dadas)
    144
    Gracias (Recibidas)
    154

    Instalar juntos yafaray 0-1-1 y yafaray dt-420 versión en desarrollo

    Al intentar instalar la versión de desarrollo de Yafray, me he encontrado con un pequeño problema. Aunque en teoría, puede trabajar conjunta-mente con la versión estable, se produce un cruce en las claves del registro de Windows. O al menos a mí me ha pasado.

    -yaf_ui_org.png
    Ejecutamos el instalador de Yafray 0.1.1, lo ponemos en el directorio por defecto, (¿:\archivos de programa\Yafray).

    Si todo ha ido bien, tenemos el YafRay_ui, py en la carpeta /scripts de Blender (1). Al abrirlo con un editor de texto, vemos en la cabecera (2) la versión correcta.

    Más abajo, la clave que nos creara en el registro de Windows (3). Comprobamos que lo ha hecho (4) y que las rutas son correctas (5) y (6).

    Hasta aquí todo ok.

    Procedemos a instalar la versión de desarrollo, a día de hoy, la dt-420 para Windows 32. Enlace, https://static, Yafray.org/unstable/Y...Windows 32.exe.

    -yaf420_conflict.png
    Ejecutamos el instalador, que se nos instala por defecto en? :\archivos de programa\yafaraydevbranch. (1) y nos copia en la carpeta /scripts el YafRay_ui y, encima del anterior (2) borrando el original. Lo comprobamos (3) abriéndolo. Vemos que también nos ha machacado (4) las claves del registro (5) y nos ha cambiado la ruta del installdir, (6).

    Hasta aquí el problema, ahora la solución.

    -solucion_yaf_dt.png
    Desinstalamos ambos, volvemos a instalar primero la versión 0.1.1, (la estable).

    Guardamos una copia del YafRay_ui, py e instalamos la versión de desarrollo (dt-420 Windows 32) en la ruta por defecto? :\archivos de programa\yafaraydevbranch. Creamos las claves en el registro, que no crea el programa (en mi caso no lo hizo) (1) y le damos la ruta correcta al installdir (2).

    Editamos el YafRay_ui, py que nos ha colocado, renombramos a YafRay_uidev, py, (3) y cambiamos la cabecera a 0.1.2 para distinguirla en el menú script/render de Blender(4). Finalmente, cambiamos el nombre de la clave que el script buscara al ejecutarse, para encontrar la ruta a installdir, (5).

    Guardamos este script, YafRay_uidev, py (6) y colocamos otra vez nuestra copia guardada de YafRay_ui, py.

    Antes de comprobar que todo funcione, recordad que es recomendable reiniciar el (*.blend) o Blender, antes de cambiar entre una y otra versión de Yafray.
    Miniaturas adjuntas Miniaturas adjuntas -yaf_ui_org.png   -yaf420_conflict.png   -solucion_yaf_dt.png  
    Última edición por povmaniaco; 30-11-2009 a las 20:34

Temas similares

  1. Instalar Yafray de Blender en Windows XP
    Por piticodelechuza en el foro Modelado
    Respuestas: 3
    : 20-09-2011, 08:43
  2. Blender Imposible instalar YafRay
    Por kmk37 en el foro Problemas con Programas
    Respuestas: 4
    : 29-03-2009, 21:10
  3. Instalar YafRay en Ubuntu 8 04
    Por renderiche en el foro Plugins
    Respuestas: 5
    : 09-05-2008, 11:28
  4. Nueva versión de Yafray v 0 0 8-2
    Por sharek en el foro Noticias
    Respuestas: 19
    : 14-07-2005, 14:54
  5. Versión Yafray compilada reciente
    Por otisnet en el foro Peticiones y Búsquedas
    Respuestas: 6
    : 17-06-2005, 00:21