Gracias Gracias:  0
Resultados 1 al 8 de 8

Tema: Compilando blender: bullet2linmath error

  1. #1
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Compilando blender: bullet2linmath error

    Hola.
    Nuevo disco duro, nueva época de compilación de blender, ergo nuevos errores.
    Me sale esto en la primera compilación, recién configuradas las librerías:

    Código:
    Configuring program blender
    scons: done reading SConscript files.
    scons: Building targets ...
    Compiling ==> 'AUD_C-API.cpp'
    In file included from intern/audaspace/intern/AUD_C-API.cpp:32:
    intern/audaspace/intern/AUD_PyInit.h:30:20: error: Python.h: No existe el fichero ó directorio
    Compiling ==> 'AUD_SilenceReader.cpp'
    In file included from intern/audaspace/intern/AUD_C-API.cpp:32:
    .
    .
    .
    ¿me falta alguna librería? tengo estas:

    Código:
     subversión build-essential gettext \
     libxi-dev libsndfile1-dev \
     libpng12-dev libfftw3-dev \
     libopenexr-dev libopenjpeg-dev \
     libopenal-dev libalut-dev libvorbis-dev \
     libglu1-mesa-dev libsdl-dev libfreetype6-dev \
     libtiff4-dev libsamplerate0-dev libavdevice-dev \
     libavformat-dev libavutil-dev libavcodec-dev libjack-dev \
     libswscale-dev libx264-dev libmp3lame-dev python3.1-dev
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

  2. #2
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Re: Compilando blender: bullet2linmath error

    Bueno, he solucionado eso: en el user-config.py tenía definida otra versión de python.
    Ahora el error es otro:

    Código:
    Compiling ==> 'AUD_C-API.cpp'
    intern/audaspace/intern/AUD_C-API.cpp: In function ‘PyObject* AUD_initPython()’:
    intern/audaspace/intern/AUD_C-API.cpp:215: error: void value not ignored as it ought to be
    intern/audaspace/intern/AUD_C-API.cpp:217: warning: deprecated conversión from string constant to ‘char*’
    scons: *** [/home/klopes/blender-svn/build/linux2/intern/audaspace/intern/AUD_C-API.o] Error 1
    scons: building terminated because of errors.
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

  3. #3
    Senior Member Avatar de cluezz
    Fecha de ingreso
    Jan 2005
    Ubicación
    Malasaña
    Mensajes
    603

    Re: Compilando blender: bullet2linmath error

    A mí me compila sin problemas después de instalar todas estas a lo bestia como dice aquí.

    build-essential scons g++ libx11-dev libgl1-mesa-dev libxi-dev zlib1g-dev libpng12-dev libglu1-mesa-dev libjpeg62-dev libfreetype6-dev libtiff4-dev libopenexr-dev libsdl1.2-dev libopenal-dev python2.6-dev libfftw3-dev libsamplerate0-dev libjack-dev libavformat-dev libxvidcore4-dev libogg-dev libfaac-dev libfaad-dev libx264-dev libmp3lame-dev libvorbis-dev libtheora-dev libswscale-dev libavdevice-dev subversión

    Versión de python: 2.6.5

    ¿con qué distro estas?

  4. #4
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Re: Compilando blender: bullet2linmath error

    Con xubuntu 10.04.
    Te puedo decir que esta todo copiado tal cual de la 9, donde sí funcionaba todo.
    Acabo de meter algunas que me faltaban en esa lista y sigue dando el error, el mismo, aunque ahora es en el fichero AUD_SequencerFactory.cpp.

    EDITO:
    Bueno, parece que ahora esta compilando bien. He tenido que cambiar Python 3.1 (también estaba con la 2.6), veremos qué sale.
    ¡Chas gracias!
    Última edición por Klópes; 20-08-2010 a las 21:26
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

  5. #5
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Re: Compilando blender: bullet2linmath error

    carajo, pues no funciona :_( da fallo de segmentación

    En resumen: si compilo con python 2.6 me dice esto al compilar:
    Código:
    scons: Building targets ...
    Compiling ==> 'AUD_C-API.cpp'
    Compiling ==> 'AUD_PyAPI.cpp'
    intern/audaspace/intern/AUD_C-API.cpp: In function ‘PyObject* AUD_initPython()’:
    intern/audaspace/intern/AUD_C-API.cpp:215: error: void value not ignored as it ought to be
    intern/audaspace/intern/AUD_C-API.cpp:217: warning: deprecated conversión from string constant to ‘char*’
    scons: *** [/home/klopes/blender-svn/build/linux2/intern/audaspace/intern/AUD_C-API.o] Error 1
    intern/audaspace/Python/AUD_PyAPI.cpp:2905: error: variable ‘PyModuleDef audmodule’ has initializer but incomplete type
    intern/audaspace/Python/AUD_PyAPI.cpp:2906: error: ‘PyModuleDef_HEAD_INIT’ was not declared in this scope
    intern/audaspace/Python/AUD_PyAPI.cpp: In function ‘void PyInit_aud()’:
    intern/audaspace/Python/AUD_PyAPI.cpp:2920: error: return-statement with a value, in function returning 'void'
    intern/audaspace/Python/AUD_PyAPI.cpp:2923: error: return-statement with a value, in function returning 'void'
    intern/audaspace/Python/AUD_PyAPI.cpp:2926: error: return-statement with a value, in function returning 'void'
    intern/audaspace/Python/AUD_PyAPI.cpp:2928: error: ‘PyModule_Create’ was not declared in this scope
    intern/audaspace/Python/AUD_PyAPI.cpp:2930: error: return-statement with a value, in function returning 'void'
    intern/audaspace/Python/AUD_PyAPI.cpp:2941: warning: deprecated conversión from string constant to ‘char*’
    intern/audaspace/Python/AUD_PyAPI.cpp:2972: error: return-statement with a value, in function returning 'void'
    scons: *** [/home/klopes/blender-svn/build/linux2/intern/audaspace/Python/AUD_PyAPI.o] Error 1
    scons: building terminated because of errors.
    y si lo hago con python 3.1 lo hace, pero no funciona
    Última edición por Klópes; 21-08-2010 a las 14:10
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

  6. #6
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Re: Compilando blender: bullet2linmath error

    Bien, pues sigo con mi reto personal monologado.
    He recompilado python, sin resultado.
    Estoy probando las opciones de comando, he probado sin GLSL, sin sonido, sin joystick... sin embargo parece funcionar perfectamente sin el entorno gráfico, el modo debug no dice nada raro... en fin, voy a tener que luchar contra los drivers de NVidia. Igual pruebo con una versión inferior.

    EDITO: ya esta.
    He actualizado el driver de NVidía y funciona. Parece que no estaba bien instalado el anterior, o algo. Hay que ver qué mal da semejante tontería.
    Última edición por Klópes; 24-08-2010 a las 13:20
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

  7. #7
    blenderniaco Avatar de angelsan
    Fecha de ingreso
    Mar 2009
    Ubicación
    Valencia
    Mensajes
    704

    Re: Compilando blender: bullet2linmath error

    Madre mia, vaya pelea épica... me alegro que lo solucionaras
    En mi caso, me he vuelto bastante comodón y tiro por la calle de en medio bajando las compilaciones de graphicall, ahora bien, el gustazo de hacerlo tu mismo ya lo tienes

    saludos

  8. #8
    Moderador Avatar de Klópes
    Fecha de ingreso
    Jul 2005
    Ubicación
    Estuve el día que llovió en los Monegros
    Mensajes
    7,988

    Re: Compilando blender: bullet2linmath error

    Ya te digo.
    Pero el gustazo de verdad es modificar el código. Más fácil que nunca...
    ...y estaba superbueno.
    Y miré su perfil. Y vi que era amigo de Daniela. Puaf.


    Dos niñas en el parque

    no se elevará, nunca más

Temas similares

  1. Compilando video tutoriales de Cinema 4D
    Por Renderfeed en el foro Esta es mi página...
    Respuestas: 2
    Último mensaje: 15-05-2014, 11:46
  2. Blender Blender error al exportar exe
    Por dmfernandez2 en el foro Problemas con Programas
    Respuestas: 7
    Último mensaje: 11-01-2014, 14:31
  3. Blender Error Mirror Blender
    Por Marckandres en el foro Modelado
    Respuestas: 6
    Último mensaje: 07-01-2014, 18:01
  4. Problema compilando Blender
    Por chronoh en el foro Infografía General
    Respuestas: 1
    Último mensaje: 06-07-2007, 01:16
  5. Problema compilando Blender openEXR
    Por cluezz en el foro Problemas con Programas
    Respuestas: 12
    Último mensaje: 05-02-2006, 00:25

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •