Gracias Gracias:  2
Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 15 de 18

Tema: Problema al Bumpear una textura y ayuda con mapas especiales

  1. #1
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Question Problema al Bumpear una textura y ayuda con mapas especiales

    Bueno ya he terminado el modelo y las texturas pero tengo un problema al hacer las normales, como veis en la imagen la luz que enfoca se aplica de forma distinta dependiendo de cada pieza del modelo. ¿Hay alguna forma de arreglarlo y que se vea homogéneo? La luz afecta bien a la superficie, pilla la profundidad y tal, pero ahí no; no se porque hace eso, de hecho el brazo y el pecho son casi del mismo color.

    Además me gustaría hacer un mapa de Refflection y de Ambient Occlusion, ya he hecho el Specular. ¿Alguien sabe como se hace?

    Gracias por la ayuda.
    Miniaturas adjuntadas Miniaturas adjuntadas Problema al Bumpear una textura y ayuda con mapas especiales-prueba-5.png  
    Última edición por Amnoon; 28-09-2012 a las 03:48

  2. #2
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    ¿si renderizas la imagen sin el normal map, esas diferencias de color no aparecen?
    Proba de hacer un render sin las texturas de color, sólo el normal map, ahí vas a poder apreciar bien de que manera influye el NMap.
    ¿Cómo generaste el NMap? Me resulta extraño que todas las parten tengan un borde como si cada región tuviese volumen propio. Eso es lo que te esta causando problemas creo. Es como que cada pieza tuviese un bump pero en las costuras esa "altura" varía de manera que se ve distinto a la luz.
    Lo bordes deberían verse sólo donde la geometría tiene volumen. si las manos, brazos y cuerpo, por ejemplo, tienen una superficie uniforme sin variación de "altura" entre ellas, esas piezas no deberían distinguirse mucho del color de fondo de la imagen (normal map), resaltarían sólo las uñas y los ojos por ejemplo.

    Reflection Map, creo que no ataña al modelo sino al entorno. Donde el objecto es más o menos reflectivo lo regulas con el specular map que ya hiciste.
    Ambient Occlusion: ¿Qué render estas utilizando? Una opción simple es generar un material AO y forzar en el render que use ese material (dependiendo del render) y ahí generas un RenderToTexture.

    Espero que te sirva.
    Esteban

  3. #3
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    Lo he hecho con Pixplant, aunque con Xnormal también pasa. No, sin el bump, no aparecen esas diferencias. Pensé en que la rotación de la zona del pecho influye, es decir los brazos están colocados de forma horizontal y el pecho vertical, y eso puede influir a como le da la luz, pero no estoy seguro. Yo solo género el normal de la textura, no uso el modelo.

    ¿Como podría hacerlo para que no apareciesen esos bordes qué tu dices? ¿Con otro programa?

    El Refflection creo que se como hacerlo, pero el Ambient, debería aplicarle el bump al modelo para que guarde los pliegues y esas cosas de la textura, y luego el render to texture?

  4. #4
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    una cosa que puedes probar es con Photoshop retocar los bordes, de manera que desaparezcan. (el mismo color del fondo) y luego volver a convertir la imagen en normal Map.
    http://developer.nvidia.com/content/...dobe-photoshop
    http://www.youtube.com/watch?v=KG3pTxgZdsI

    no sé que tanta diferencia va a haber de un programa a otro...
    http://www.crazybump.com/
    ... porque se me hace que la imagen con la textura tiene el fondo (fuera de las piezas del modelo) de un color completamente distinto, de manera que cuando generas el NMap el programa cree que el fondo tiene otra elevación y ahí es cuando suergen esos cantos en las costuras.

    El AO no lo vas a poder generar de esa manera ya que los bumps no hacen modificaciones en la geometría, sólo se ven si hay luces en la escena, y al generar Ambient Occlusion las luces se ignoran. De manera que la rugosidad no la vas a ver. Sólo si fuera un displace map.

    Ya que no tienes un objeto en HighPoly, ese AO que quieres (con los detalles de la textura) no lo vas a poder hacer.
    Pero podrías trucarlo un poco.
    1_desactivar la textura del modelo, solo darle un color blanco o gris y sólo dejar el NormalMap activado. (para que se vean los bumps) Subile el valor exagerando para que los bumps sean bien definidos.
    2_apagar las luces directas de la escena y sólo dejar Global Illumination activo, de manera de no tener sombras directas sino más bien ambientales.
    3_poner el modelo en el centro de la escena con un plano que le sirva de piso. El piso debe ser de color claro, aunque los vas a tener que regular para obtener luminocidad necesaria.
    4_Renderizar y hacer los ajustes necesarios de luz.
    4_ Hacer un RenderToTexture "CompleteMap"

    De esa menera vas a obtener una textura blanca o clara con sólo los detalles del NMap.
    No es lo mejor pero puede funcionar.

  5. #5
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    Pues probaré con los tutoriales que me has pasado a ver. Adjunto la textura. ¿Ocurre el error ese que comentasí
    Miniaturas adjuntadas Miniaturas adjuntadas Problema al Bumpear una textura y ayuda con mapas especiales-texturemap.jpg  

  6. #6
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    si, fijate el contraste que hay entre el color de la piel (bien claro) y el fondo.
    Cuando generas un normal map, las rugosidades se obtienen da una escala de grises o de tonos, como es en tu caso.
    La zonas claras se van a traducir en el modelo en zonas más "elevadas" (o al revez, no me acuerdo). Si miras tu NMap, vas a ver que esa costura bien marcada se produce en las zonas de la piel, porque el programa piensa que esa zona (al ser más clara que el fondo) representa una elevación.

    Para evitar esto tienes que extender las zonas un poco más afuera del "unwrap" . Nunca es conveniente que las zonas de la textura terminen justo (o con poco margen) de donde están los patchs del unwrap. De esta manera si bien esa costura la vas a tener lo mismo, pero por lo menos va a estar fuera de la zona visible de la textura.

    Espero que se entienda lo que escribí.
    Última edición por estebang; 28-09-2012 a las 15:04

  7. #7
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    http://www.youtube.com/watch?v=P4p23...eature=related
    fijate en el minuto 4:48 a lo que me refiero de extender las zonas.

  8. #8
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    aaa ok pues probaré. Tiene pinta de ser eso.

  9. #9
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    Pues no, sigue pasando, hasta normalizando las zonas en Photoshop ni expandiendolas...

  10. #10
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    raro, raro... eso pasa sólo en los viewports o si hacés un render también.
    Subí la imagen de como quedo ahora el normal map

  11. #11
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    Vale, el principal problema es que el busto esta girado en la textura mientras el cuerpo en forma horizontal, parece que eso hace que la luz afecte al modelo de forma distinta. Si no logro solucionarlo, subiré el render con el mapa actualizado (con el nuevo uv) y el mapa en cuestión.

  12. #12
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    He hecho una prueba rápida (y a lo rudo), volteando el busto y expandiendo la textura y homogeneizandola. Sin Bump se ve bien, las zonas demasiado bruscas de color es por el tono de piel usado pues lo he hecho rápido para ver como queda. He sacado las normales de eso con PixPlant y pasa lo mismo tanto en el render como en el viewport (con CreazyBump también pasa). Lo único que queda, es que lo normal es que pasen esas cosas y yo he cortado por zonas demasiado visibles.

    De hecho hasta coviertiendo todo el mapa de normales solo con un color, que no debería afectar nada a la superficie hace lo mismo. Eso si que es extraño.
    Miniaturas adjuntadas Miniaturas adjuntadas Problema al Bumpear una textura y ayuda con mapas especiales-prueba-6.png  
    Última edición por Amnoon; 28-09-2012 a las 20:26

  13. #13
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    lo que te puede aconcejar ahora a la apuradas, es lo que dije de photoshop.

    Importa el nMap en Photoshop, retoca la imagen de manera que el color del fondo y el color de donde esta la piel sea uno solo. Es decir borra los bordes. de manera que lo único que se vea en la imagen sean sólo las cosas que quieres resaltar.
    Después exporta la imagen desde Photoshop como dds Nmap. Fijate el link del primer video que posteé.

    por ahora no se me ocurre nada más ...

  14. #14
    Miembro Nuevo
    Fecha de ingreso
    Oct 2011
    Mensajes
    26

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    Si, eso lo he probado si de hecho, hasta aplicando este mapa de un solo color pasa lo mismo. Cosa que no le veo yo el sentido por ningún lado.
    Miniaturas adjuntadas Miniaturas adjuntadas Problema al Bumpear una textura y ayuda con mapas especiales-texturemap.jpg  

  15. #15
    Senior Member
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115

    Re: Problema al Bumpear una textura y ayuda con mapas especiales

    que material estas usando? que render?

    Standard->Bump->Normal Bump->Bitmap

    si quieres subi el modelo y miro a ver si encurntro algo inusual. O si no deseas por razones personales, por lo menos una parte del modelo que incluya disteintas piezas, pej. brazo y parte del pecho.

Página 1 de 2 12 ÚltimoÚltimo

Temas similares

  1. ayuda super urgente Problema con textura
    Por gilberth3094 en el foro Materiales y Texturizado
    Respuestas: 8
    Último mensaje: 19-01-2014, 02:01
  2. aYUDa Problema para Convertir Multi-material en Textura
    Por MaXimiliaNMetaL en el foro Materiales y Texturizado
    Respuestas: 1
    Último mensaje: 22-03-2013, 00:00
  3. Respuestas: 5
    Último mensaje: 23-09-2012, 02:10
  4. problema con skin y mapas procedurales ayuda por favor
    Por danielblanco3d en el foro Animación y Rigging
    Respuestas: 8
    Último mensaje: 13-07-2008, 16:04
  5. Hacer mapas de textura
    Por Turriano en el foro Materiales y Texturizado
    Respuestas: 12
    Último mensaje: 12-12-2006, 19:02

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •