Gracias Gracias:  2
Resultados 1 al 8 de 8

Tema: Problema con Blender Game Engine

  1. #1
    Senior Member Avatar de Juani
    Fecha de ingreso
    Jul 2015
    Ubicación
    Montilla (Córdoba)
    Mensajes
    421

    Problema con Blender Game Engine

    Buenas a todos, soy un aficionado a blender y nuevo en el foro, tengo un problema con el motor de juegos de blender y es que cuando lanzo el game engine
    con tres scripts para las físicas de un vehículo, el programa se cierra directamente.
    Me gustaría saber si a alguien le ha pasado y sabe como solucionarlo, por cierto mi versión es la 2.72b para Windows 8.
    Gracias de antemano.

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,201

    Re: Problema con Blender Game Engine

    Pasa a veces cuando hay alguna cosa cruzada o la versión con la que se realizó, era más antigua.
    A veces con hacer un APPEND de toda la escena a un blend nuevo, se soluciona solo.


    Prueba a abrir un blend vacío.. y haces un FILE > APPEND y cargas la escena (Scene)
    (debes de borrar la escena vacía que tienes al abrir el blend y así se quedará la que acabas de cargar como principal).

    Si no lo arreglas así, prueba a subir el blend
    http://www.pasteall.org/blend/
    Se carga el blend.. se espera un momento y copias la nueva dirección que sale con unos números detrás.
    Luego la pegas aquí.

  3. #3
    Senior Member Avatar de Juani
    Fecha de ingreso
    Jul 2015
    Ubicación
    Montilla (Córdoba)
    Mensajes
    421

    Re: Problema con Blender Game Engine

    Muchas gracias por el interés y tu perdida de tiempo, añadiendo la escena a un nuevo blend no se ha corregido el problema.
    Te dejo la dirección donde lo he subido pasteall.org/blend/37275

  4. #4
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,201

    Re: Problema con Blender Game Engine

    A mi no me peta.... aunque tampoco hace ninguna acción.

    Mira a ver si si puede ser que no tengas activada la opción de auto-ejecutar scripts (no estoy seguro que sea ese el fallo, pero por probar...).

    Esta en la ventana de User Preferences > File
    Luego guardas esa nueva configuración con Save User Settings para que cuando se vuelva a abrir blender, este activa.

    Problema con Blender Game Engine-user.jpg

  5. #5
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,201

    Re: Problema con Blender Game Engine

    Por cierto, yo siempre uso la última versión que hay en la página de Blender que en estos momentos es la 2.75a
    http://www.blender.org/download/

  6. #6
    Senior Member Avatar de Juani
    Fecha de ingreso
    Jul 2015
    Ubicación
    Montilla (Córdoba)
    Mensajes
    421

    Re: Problema con Blender Game Engine

    Nada no hay manera, ejecuto los scripts individualmente y funciona excepto el de las físicas, mientra tenga un error la ejecución no pasa nada y lo puedo ver en la consola, cuando se supone que esta arreglado, al ejecutar el juego, se cierra.Me da la sensación de que es al importar PhysicsConstraints.

    Voy a probar a instalar la última versión a ver que ocurre.
    Muchas gracias por tu tiempo, ya te contaré.

  7. #7
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,201

    Re: Problema con Blender Game Engine

    ¿Puede ser que requiera de que esté el Python instalado en tu ordenador?
    Se, que estas versiones llevan el python en una carpeta pero si el problema fuera que necesita de alguna librería que no va incorporada, podría se el motivo del fallo.

    De python no se nada más que lo básico..
    Última edición por Soliman; 26-07-2015 a las 13:03

  8. #8
    Senior Member Avatar de Juani
    Fecha de ingreso
    Jul 2015
    Ubicación
    Montilla (Córdoba)
    Mensajes
    421

    Re: Problema con Blender Game Engine

    ¡¡¡Por fin..¡¡¡, un millón de gracias, ha vuelto mi ilusión, he cambiado la versión a la 2.75, también, había algún error por mi parte, no hacía ninguna acción porque los objetos no tenían bien las físicas, pero eso es lo de menos, lo importante es que se cerraba y ya no lo hace.Si a alguien le ocurre lo mismo pudiera ser que fuese un fallo de la versión 2.72b.
    No se como agradecértelo de nuevo.
    Un millón de gracias y un saludo.

Temas similares

  1. Respuestas: 2
    Último mensaje: 07-03-2015, 18:51
  2. Blender Problema al emparentar objeto a un objeto con Brick Logics Blender Game Engine
    Por joelrodrigos en el foro Problemas con Programas
    Respuestas: 4
    Último mensaje: 29-01-2015, 14:48
  3. Blender Blender Game engine en Red
    Por 3dpoder en el foro Blender Art Magazine nº 14
    Respuestas: 0
    Último mensaje: 08-04-2014, 09:30
  4. Game engine Blender
    Por MAYAMAN en el foro Videojuegos
    Respuestas: 2
    Último mensaje: 14-03-2010, 20:32
  5. Blender game engine
    Por GEKKONIDAE en el foro Blender
    Respuestas: 21
    Último mensaje: 09-10-2008, 14:27

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •