Gracias Gracias:  4
Resultados 1 al 10 de 10

Tema: Problemas al ejecutar Append de blender

  1. #1
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    Problemas al ejecutar Append de blender

    Hola a tod@s.

    Estoy haciendo un trabajo en Blender 2.78 y el archivo por algún motivo me presenta fallos tales como no ejecutar las luces o físicas. Por ello, quiero coger todos los objetos de este trabajo y pasarlo a un nuevo archivo con el fin de subsanar dichos fallos. Llevo varios intentos de diversas formas pero no consigo importar el trabajo al nuevo archivo, al menos el 100% de este:

    - Importando un ".dae" me deforma ciertas mayas de algunos objetos.

    - Importando un ".fbx" no me muestra todos los objetos, a pesar de que en el outliner aparentemente figuran todos (y no están ocultos)

    - Mediante "append" si selecciono todos los objetos me cierra el programa (no se si por un fallo de rendimiento de mi PC o por que), e incluso seleccionando un máximo de solo 6-7 archivos tambien me cierra blender. La unica solucion que encontre, uno a uno, algo tedioso al contar con más de 200 objetos, pero rápidamente me percaté de que los objetos no guardaban sus coordenadas.

    ¿Es normal lo que me pasa en esos 3 casos?, ¿alguna solución para exportar todo el trabajo del archivo dañado a uno nuevo?

    Problemas al ejecutar Append de blender-sin-titulo.png

    Gracias.

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    9,699

    re: Problemas al ejecutar Append de blender

    Puedes probar ha hacer un APPEND pero de toda la escena.
    O sea, en un blend nuevo y vacío, haces Append de la escena (SCENE) y borras la escena del primer blend, y te quedará la del segundo.

    A ver si así no te da fallo.

    Problemas al ejecutar Append de blender-escena.jpg

  3. #3
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    re: Problemas al ejecutar Append de blender

    Gracias. Fué lo último que probé antes de publicar este tema, pero Blender deja de funcionar.

    Problemas al ejecutar Append de blender-sin-titulo.png

  4. #4
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    9,699

    re: Problemas al ejecutar Append de blender

    Igual es un problema de memoria. Divídelo en partes, aunque me suena que si tienes físicas, pueda ser ese el error.

    ¿Cuanto pesa el .blend? (o sea, cuantos megas tiene...)

    Puedes desactivar las físicas desde MODIFICADORES, desmarcando el ojito que tiene, por si fuera ese el error.

    Problemas al ejecutar Append de blender-particulas.jpg

  5. #5
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    re: Problemas al ejecutar Append de blender

    Solo pesa 20.5MB, muy poco.

    He desmarcado físicas pero no se muestran las luces. Quiero cambiar de archivo pues creo que algo tiene este en su configuración que presenta esos fallos, pero como comento, ningún de las 3 formas que use para exportar me sirve. Lo mas raro es lo de append, que si selecciono todos los objetos, se me cierra el programa, por lo que me hace pensar que también pueda ser por rendimiento de mi PC.

  6. #6
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    Re: Problemas al ejecutar Append de blender

    Solucionado. No como quería hacerlo, pero ya esta cambiado de archivo.

    He importado todos los objetos del archivo dañado a uno nuevo con ".dae". Los objetos que se importaban de mala forma los he añadido al nuevo archivo uno a uno mediante "append" y aun así, alguno seguían importando con deformaciones en su geometría, por lo que estos los importe de nuevo con grupos de ".fbx".

    En el nuevo archivo si se ejecutan las luces (por algún motivo, en el anterior se convirtieron todas en "emisión"), y las físicas aun no he probado, pero confío que también se ejecuten como deben.

    Gracias.

  7. #7
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    Re: Problemas al ejecutar Append de blender

    Otra duda (asi no creo más temas)

    Al importar los objetos al nuevo archivo, estos lo hacen con la maya en triangulados en lugar de polígonos ¿como puedo corregirlo sin tener que eliminarlos uno a uno?

    Problemas al ejecutar Append de blender-sin-titulo.png

  8. #8
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    9,699

    Re: Problemas al ejecutar Append de blender

    En modo edición, seleccionas todo y ALT+J

    Suele funcionar con modelos sencillos, si son muy complejos, puede pasar que algunas zonas no te las cambie y te tocará seleccionarlas luego y volver a probar.

    Problemas al ejecutar Append de blender-f.jpg

  9. #9
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    9,699

    Re: Problemas al ejecutar Append de blender

    Por cierto, veo imágenes más oscuras. Creo que debería hacer luego un Ctrl+N para recalcular normales y antes un W > Remouve Doubles para borrar vértices duplicados.

    Recuerda hacer una copia antes por si escacharra el modelo

  10. #10
    Miembro Avatar de Dempo
    Fecha de ingreso
    May 2014
    Ubicación
    Murcia
    Mensajes
    69

    Re: Problemas al ejecutar Append de blender

    Ole! que grande! Muchas gracias Soliman! Solucionado.

    Si, no se por que en esa imagen da la impresión de algunas normales apuntando en dirección contraria, pero estaban bien, pero gracias también por ello.

Temas similares

  1. Blender Link y Append en Blender
    Por Mackbay en el foro Modelado
    Respuestas: 6
    Último mensaje: 11-09-2015, 13:20
  2. Blender append Blender 2 5 alpha 1
    Por birckof en el foro Modelado
    Respuestas: 2
    Último mensaje: 01-03-2010, 23:04
  3. append Link entre ficheros Blender
    Por Pistolario en el foro Modelado
    Respuestas: 1
    Último mensaje: 06-05-2008, 16:37
  4. append dos escenas en Blender
    Por jogarbel en el foro Animación y Rigging
    Respuestas: 6
    Último mensaje: 18-05-2005, 13:00
  5. Problemas al ejecutar backburner2
    Por nigmaunomx en el foro Problemas con Programas
    Respuestas: 0
    Último mensaje: 06-06-2004, 23:09

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •