Buenos dias al foro.

Amigos en esta oportunidad busco ayuda en el foro por la siguiente duda.
He tenido problemas de rendimiento con mi pc actual, la cual compré específicamente para trabajar con v-ray and 3dsmax, ademas de otros software como Revit y Autocad. Dejo en las siguientes líneas las especificaciones de la laptop que compré:

Windows 10 Home / Windows 10 Pro
Latest 6th Gen. Intel® Core™ i7 processor
GeForce® GTX 960M graphics with higher performance
17.3" Full HD (1920x1080)
NVMe M.2 SSD by PCIe Gen3 X4 up to 2200MB/s speed(Optional)
USB 3.0 Type-C reversible plug
Nahimic Sound Technology delivering 360⁰ immersive audio experience
Audio Boost enhancing the gaming headset sound detail and sound stage
Keyboard by Steelseries with better tactile feedback
Exclusive SHIFT technology boosts performance under controlled noise & temperature
Exclusive Cooler Boost 3 Technology
Matrix Display supporting 4K output up to 2 external monitors
8 gb de ram

Ahora bien, fuera de unos breves momentos en los que el puntero parece desplazarse en cámara lenta no he tenido problemas con la laptop.
Los problemas se suscitan cuando estoy renderizando. Tengo 3dsmax 2017 y v-ray 3.4 y estoy haciendo unas pruebas de renders.

La escena es la siguiente, un v-ray sun, un v-ray plane, y unos cuantos árboles, nada del otro mundo.
La laptop renderiza bastante bien cuando me mantengo en un rango entre los 2 millones y 2 1/2 millones de polígonos, pero al acercarme a los 4 millones el sistema falla, y la computadora queda completamente inservible, debo presionar en botón de reinicio manualmente para restaurar el sistema nuevamente. Los settings son default por quick setting, para interior o exterior, en ambos casos ocurre lo mismo. La cámara es una Phisical Cam con seteo por default menos la cantidad de iso que la he llevado a 200. Un vraysky default de vray sun. No creo que tenga más de 10 texturas en total.

Quisiera saber cuales son las posibles causas de esta falla? Podría ser que estoy exigiendo demasiado al equipo? Realmente no creo que sea esta último.
Vale Acotar también que durante la ejecución de la escena la interfaz de usuario se pone muy lenta, sera que hay que configurar la tarjeta de vídeo dentro de algún renglón específico del max y no lo sé?

En fin, quedo esperando sus comentarios y dando las gracias de antemano.