Gracias Gracias:  0
Resultados 1 al 11 de 11

Tema: Reproducir aVI: Pocos fps la primera vez, bien la segunda

  1. #1
    Senior Member
    Fecha de ingreso
    Jun 2005
    Mensajes
    868

    Exclamation Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Buenas, tengo un problema que no consigo solucionar.

    Hago una animación en blender, con avi raw a 25 fps y cuando por ejemplo desde el Blender Sequencer le doy a reproducir la primera vez va a golpes (pocos fps) y la segunda va fino y normal.

    Me pasa igual si lo hago con el Gmplayer, la verdad es que no entiendo esto...

    Como puede ser que la primera vez vaya a trozos y la segunda vez fino y normal?

    Uso Linux-Ubuntu 5.04.

    A ver si alguien me puede ayudar por favor...

    Un saludo y gracias!!!

    PD: No indico ningún programa porque creo que no es problema de ninguno de ellos

  2. #2
    Ninja Fever Avatar de Mars Attacks
    Fecha de ingreso
    Jun 2003
    Ubicación
    Castellón
    Mensajes
    12,744

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    RAW es sin comprimir, es decir, secuencia de bitmaps. Eso ocupa un montón de memoria, así que la primera vez que lo reproduce, la memoria tiene muchos fallos de información no encontrada y tarda mucho en adquirirlos. La segunda vez, ya tiene esos trozos en memoria, así que los recupera mucho más rápidamente.

  3. #3
    Senior Member
    Fecha de ingreso
    Jun 2005
    Mensajes
    868

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Gracias Mars! :D

    Una cosita, estoy renderizando unos 250 frames como secuéncias de imágenes TGA, para luego montar el video con el Blender Sequencer las abro todas le digo que Make Meta Strip, abajo de Anim selecciono "Do Sequence" y el video como lo salvo? Tga raw, avi raw...

    Es que no vea ninguna opción para comprimir con divx o algo así...

    Gracias!
    Última edición por Pinucset; 07-09-2005 a las 23:42

  4. #4
    Senior Member
    Fecha de ingreso
    Jun 2005
    Mensajes
    868

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Me dice Pepius que ponga AVI CODEC en lugar de AVI RAW, pero a mi no me sale esta opción.

    Supongo que tengo instalados los codecs, apt-get install w32 codecs, liv etc...

    Tengo que instalar algo en especial?

    Un saludo y gracias!

  5. #5
    Senior Member
    Fecha de ingreso
    Jun 2005
    Mensajes
    868

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Bueno, en el chat de Blender me dicen que el AVI CODEC no esta soportado para Linux y que no se puede comprimir con ningún codec desde el Blender mismo... de momento, ya que hay el SOC FFMPEG que permitira desde el Blender Sequencer comprimir en xvid, divx etc.

    De momento tengo que tirar de programas del estilo de transcode etc. para comprimir archivos

    Un saludo y gracias a todos, me voy a dormir

  6. #6
    Aprendiz
    Fecha de ingreso
    Jan 2005
    Ubicación
    Madrid
    Mensajes
    2,280

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    En este hilo hay alguien que ofrece una versión compilada con soporte para ffmpeg, de momento para linux:
    http://blender.org/forum/viewtopic.php?t=6908
    To use, just import a video file into the sequencer, or select FFMpeg as the output format. The controls are fairly straightforward: select the video format(mpeg2, avi, etc) on the panel that pops up, and select a codec if the selected format allows it.

  7. #7
    BlenderAdicto Avatar de 8tintin
    Fecha de ingreso
    Jun 2002
    Mensajes
    1,694

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Escoge AVI JPEG. Aunque aún así será sin compresión de video.

    O pruebas la versión que ha puesto viriathus o usas el mencoder con la fórmula:

    mencoder ORIGINAL -ofps 25 -vop scale=640:360 -sws 2 -ovc lavc -lavcopts vcodec=mpeg4:vpass=1:vhq:keyint=250:vbitrate=VALOR -oac copy -o SALIDA.AVI

    Donde en ORIGINAL tienes que poner el nombre del video a comprimir. En -ofps tienes que poner los frames por segundo. En scale=640:360 tienes que poner la resolución del video. Y en VALOR el vbitrate (con 256 queda de lujo). Ah y en SALIDA.AVI el nombre que quieras darle.

    El transcode no lo uso, pero será igual de potente.

    Saludos.

  8. #8
    BlenderAdicto Avatar de Caronte
    Fecha de ingreso
    Dec 2004
    Ubicación
    Valencia-España
    Mensajes
    14,691

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Cita Iniciado por 8tintin
    Escoge AVI JPEG. Aunque aún así será sin compresión de video.
    No. Eso es compresión JPEG (a no ser que funcione distinto en linux), para que no tenga compresión hay que elegir AVI RAW
    "Algún día todo será digital". Caronte.
    Mi web: NicoDigital.com

  9. #9
    BlenderAdicto Avatar de 8tintin
    Fecha de ingreso
    Jun 2002
    Mensajes
    1,694

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Sí, funciona igual en linux. Lo que yo quería decir es que el AVI JPEG es la única salida con algo de compresión que puedes dar con blender en linux, pero que la compresión no es de video sino que es por frame. Osea, que no hay un códec que calcula los cambios de un frame a otro y en función de eso comprime más o menos, sino que cada frame ocupa un poco menos porque se guarda en jpeg.

    Saludos.

  10. #10
    BlenderAdicto Avatar de Caronte
    Fecha de ingreso
    Dec 2004
    Ubicación
    Valencia-España
    Mensajes
    14,691

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    correcto y además es un formato muy rápido para editar
    "Algún día todo será digital". Caronte.
    Mi web: NicoDigital.com

  11. #11
    Ninja Fever Avatar de Mars Attacks
    Fecha de ingreso
    Jun 2003
    Ubicación
    Castellón
    Mensajes
    12,744

    Re: Reproducir AVI: Pocos fps la primera vez, bien la segunda.

    Instalate el avidemux y comprimes ese RAW de una forma facilísima y cómoda. Es como el virtualdub de linux

Temas similares

  1. Maya Mac muy lento con pocos poligonos
    Por JuL10Mx en el foro Problemas con Programas
    Respuestas: 0
    Último mensaje: 23-08-2012, 07:53
  2. Un Clasico como pocos
    Por sejob1975 en el foro Trabajos Finalizados
    Respuestas: 14
    Último mensaje: 16-07-2008, 07:06
  3. aVI mas MP3 Con pocos recursos, que uso
    Por devnul en el foro Postproducción
    Respuestas: 2
    Último mensaje: 03-06-2005, 19:40
  4. La primera foto de familia y de momento se llevan bien
    Por Ferriz en el foro Trabajos Finalizados
    Respuestas: 34
    Último mensaje: 30-09-2004, 19:20
  5. Suavizar pocos poligonos
    Por pirkeops en el foro Modelado
    Respuestas: 5
    Último mensaje: 29-08-2004, 10:59

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •