Gracias Gracias:  0
Resultados 1 al 5 de 5

Tema: La textura UV no aparece igual en el viewport que en render

  1. #1
    Senior Member Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    131

    La textura UV no aparece igual en el viewport que en render

    Me ocurre lo siguiente con la textura de un personaje:
    La textura UV no aparece igual en el viewport que en render-personaje.png

    El ojo derecho tiene un desplazamiento diferente y el pelo de la cabeza es de otro color. Son diferencias sutiles pero no se porque ocurre la verdad, he creado un material nuevo y viendo si estaba cogiendo otra imagen o algo, pero nada. Solo tengo esa imagen y ese material, no hay más. ¡Alguna idea?
    Gracias por adelantado.

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,200

    Re: La textura UV no aparece igual en el viewport que en render

    Pues que tendrás el UV mal puesto, digo yo.
    Enseña la ventana del UV/Image Editor para ver como tienes el mapeado.

  3. #3
    Senior Member Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    131

    Blender Re: La textura UV no aparece igual en el viewport que en render

    La textura UV no aparece igual en el viewport que en render-captura.png


    Lo que he marcado de rojo es la zona de la cara. Donde está el ojo, pero de todas formas no entiendo que (esté mal o bien el UV), en el viewport se vea una cosa y en el render otra. Que por cierto, no solo se deforma el ojo de esa forma, también me he fijado que en el render, la textura está un poquito más desplazada hacia arriba.
    Miniaturas adjuntadas Miniaturas adjuntadas La textura UV no aparece igual en el viewport que en render-personaje.png   La textura UV no aparece igual en el viewport que en render-captura.png  

  4. #4
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,200

    Re: La textura UV no aparece igual en el viewport que en render

    Si has desplegado bien la malla (como se ve en la ventana UV) entonces puede ser que no tengas bien puesto en la textura de imagen la coordenada del mapeado.

    A ver si es eso...

    La textura UV no aparece igual en el viewport que en render-textura.jpg

    De todas formas, en el visor de texturas no se suele ver bien el render final si tiene por ejemplo variaciones en el tamaño, etc..
    Si quieres ver lo que se ve en el render final te puedes poner en RENDERED


    La textura UV no aparece igual en el viewport que en render-textura2.jpg

  5. #5
    Senior Member Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    131

    Blender Re: La textura UV no aparece igual en el viewport que en render

    Cita Iniciado por Soliman Ver mensaje
    Si has desplegado bien la malla (como se ve en la ventana UV) entonces puede ser que no tengas bien puesto en la textura de imagen la coordenada del mapeado.

    A ver si es eso...

    La textura UV no aparece igual en el viewport que en render-textura.jpg

    De todas formas, en el visor de texturas no se suele ver bien el render final si tiene por ejemplo variaciones en el tamaño, etc..
    Si quieres ver lo que se ve en el render final te puedes poner en RENDERED


    La textura UV no aparece igual en el viewport que en render-textura2.jpg
    El caso es que lo que te he enseñado es una misma captura de pantalla, izq se ve el viewport y derecha una ventana con el modo rendered. Pero acabo de descubrir el problema.

    La textura UV no aparece igual en el viewport que en render-captura.png

    Tenía que marcar esas 2 casillas (que vienen por defecto desmarcadas). Eso me ha arreglado el problema del desplazamiento, así la textura se ve en el render del mismo modo que como se ha pintado en el viewport:
    La textura UV no aparece igual en el viewport que en render-1.png

    La mayor diferencia estaba en el ojo derecho del personaje, era algo sutil, pero le cambiaba la expresión completamente (parecía estar enfadado xD).

Temas similares

  1. Blender no me aparece la textura en objetos con volumen
    Por biztor en el foro Materiales y Texturizado
    Respuestas: 2
    Último mensaje: 07-09-2014, 21:31
  2. Blender no me aparece la textura en objetos con volumen
    Por biztor en el foro Materiales y Texturizado
    Respuestas: 0
    Último mensaje: 07-09-2014, 13:39
  3. Maya no aparece textura en render
    Por verzotatuajes en el foro Materiales y Texturizado
    Respuestas: 0
    Último mensaje: 30-04-2013, 00:08
  4. Respuestas: 0
    Último mensaje: 01-07-2011, 19:25
  5. La textura no aparece en el lugar correcto
    Por Kali en el foro Materiales y Texturizado
    Respuestas: 3
    Último mensaje: 26-04-2008, 22:22

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •