Resultados 1 al 5 de 5

Tema: La textura uv no aparece igual en el viewport que en render

  1. #1
    Usuario Avanzado Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    132
    Gracias (Dadas)
    36
    Gracias (Recibidas)
    8

    La textura uv no aparece igual en el viewport que en render

    Me ocurre lo siguiente con la textura de un personaje:
    La textura uv no aparece igual en el viewport que en render-personaje.png

    El ojo derecho tiene un desplazamiento diferente y el pelo de la cabeza es de otro color. Son diferencias sutiles, pero no sé porque ocurre la verdad, he creado un material nuevo y viendo si estaba cogiendo otra imagen o algo, pero nada. Solo tengo esa imagen y ese material, no hay más. Alguna idea?
    Gracias por adelantado.

  2. #2
    Usuario Legendario Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    15,200
    Gracias (Dadas)
    459
    Gracias (Recibidas)
    4523

    La textura uv no aparece igual en el viewport que en render

    Pues que tendrás el UV mal puesto, digo yo.

    Enseña la ventana del UV/Image Editor para ver cómo tienes el mapeado.

  3. #3
    Usuario Avanzado Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    132
    Gracias (Dadas)
    36
    Gracias (Recibidas)
    8

    Blender La textura uv no aparece igual en el viewport que en render

    La textura uv no aparece igual en el viewport que en render-captura.png

    Lo que he marcado de rojo es la zona de la cara. Donde está el ojo, pero de todas formas, no entiendo que (esté mal o bien el UV), en el viewport se vea una cosa y en el render otra. Que, por cierto, no solo se deforma el ojo de esa forma, también me he fijado que en el render, la textura está un poco más desplazada hacia arriba.
    Miniaturas adjuntas Miniaturas adjuntas La textura uv no aparece igual en el viewport que en render-personaje.png   La textura uv no aparece igual en el viewport que en render-captura.png  

  4. #4
    Usuario Legendario Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    15,200
    Gracias (Dadas)
    459
    Gracias (Recibidas)
    4523

    La textura uv no aparece igual en el viewport que en render

    Si has desplegado bien la malla (como se ve en la ventana UV) entonces puede ser que no tengas bien puesto en la textura de imagen la coordenada del mapeado.

    A ver si es eso.

    La textura uv no aparece igual en el viewport que en render-textura.jpg

    De todas formas, en el visor de texturas no se suele ver bien el render final si tiene, por ejemplo, variaciones en el tamaño, etc.

    Si quieres ver lo que se ve en el render final te puedes poner en RENDERED.

    La textura uv no aparece igual en el viewport que en render-textura2.jpg

  5. #5
    Usuario Avanzado Avatar de Furan
    Fecha de ingreso
    Jan 2014
    Ubicación
    Alicante
    Mensajes
    132
    Gracias (Dadas)
    36
    Gracias (Recibidas)
    8

    Blender La textura uv no aparece igual en el viewport que en render

    Cita Iniciado por Soliman Ver mensaje
    Si has desplegado bien la malla (como se ve en la ventana UV) entonces puede ser que no tengas bien puesto en la textura de imagen la coordenada del mapeado.

    A ver si es eso.

    La textura uv no aparece igual en el viewport que en render-textura.jpg

    De todas formas, en el visor de texturas no se suele ver bien el render final si tiene, por ejemplo, variaciones en el tamaño, etc.

    Si quieres ver lo que se ve en el render final te puedes poner en RENDERED.

    La textura uv no aparece igual en el viewport que en render-textura2.jpg
    El caso es que lo que te he enseñado es una misma captura de pantalla, izq se ve el viewport y derecha una ventana con el modo rendered. Pero acabo de descubrir el problema.

    La textura uv no aparece igual en el viewport que en render-captura.png

    Tenía qué marcar esas 2 casillas (que vienen por defecto desmarcadas). Eso me a arreglado el problema del desplazamiento, así la textura se ve en el render del mismo modo que cómo se ha pintado en el viewport:
    La textura uv no aparece igual en el viewport que en render-1.png

    La mayor diferencia estaba en el ojo derecho del personaje, era algo sutil, pero le cambiaba la expresión completamente (parecía estar enfadado).

Temas similares

  1. Blender No aparece el material preview del Viewport shading en Blender
    Por Silverwing en el foro Problemas con Programas
    Respuestas: 5
    : 02-03-2020, 06:29
  2. Maya No aparece textura en render
    Por verzotatuajes en el foro Materiales y Texturizado
    Respuestas: 0
    : 30-04-2013, 00:08
  3. Respuestas: 0
    : 01-07-2011, 19:25
  4. Lograr color del render igual al del material editor
    Por notfound en el foro Problemas con Programas
    Respuestas: 3
    : 10-05-2011, 16:51
  5. No se ve la textura en el viewport
    Por Leander en el foro Materiales y Texturizado
    Respuestas: 12
    : 14-10-2007, 16:16