Gracias Gracias:  6
Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 15 de 21

Tema: Problema con Render y textura UV

  1. #1
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Problema con Render y textura UV.

    Hola gente,

    El caso es que ahora quería hacer un render del objeto que estoy haciendo por ver como queda y ver la evolución.

    Pero hay un problema, cuando hago el render con Interno y textura no hay problema. Pero cuando le aplico el Cycles queda con solo el material.

    Lo he intentado con el editor de nodos, pero tampoco logro hacerlo. Alguien me puede decir como solucionarlo.


    Saludos y gracias.

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    Cuando cambias de Blender Internal a Blender Cycles el material se puede activar, pero la textura la tienes que poner por nodos. (se pincha sobre USE NODES).
    Luego añades un nodo de Image Texture y un nodo de Texture Coordinate (en este caso si lo tienes UVMapeado, pues en UV)

    Problema con Render y textura UV -uv1.jpg

  3. #3
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Cita Iniciado por Soliman Ver mensaje
    Cuando cambias de Blender Internal a Blender Cycles el material se puede activar, pero la textura la tienes que poner por nodos. (se pincha sobre USE NODES).
    Luego añades un nodo de Image Texture y un nodo de Texture Coordinate (en este caso si lo tienes UVMapeado, pues en UV)

    Problema con Render y textura UV -uv1.jpg
    Ahora tiene la textura, pero queda un combinado de azul. Aun así, cuando le aplico el procesado de cycles con toda las iluminación no se muestra la textura. También he buscado la geometría, pero no encuentro como darle los valores.

    Problema con Render y textura UV -tex_cycles.png

  4. #4
    Senior Member Avatar de xmasb
    Fecha de ingreso
    Oct 2009
    Ubicación
    Castellon
    Mensajes
    144

    Re: Problema con Render y textura UV.

    El nodo de la imagen ha de ir al "color" del nodo difuse si quieres verla. Te sale azul porque lo llevas a "rugosidad"

    Problema con Render y textura UV -sin-titulo.jpg
    Última edición por xmasb; 14-08-2013 a las 21:39

  5. #5
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Cita Iniciado por xmasb Ver mensaje
    El nodo de la imagen ha de ir al "color" del nodo difuse si quieres verla. Te sale azul porque lo llevas a "rugosidad"

    Problema con Render y textura UV -sin-titulo.jpg
    Ya lo he hecho, aun así se ve azul claro también.

    Pero incluso así, no se visualiza el mapa UV. Aquí puedes verlo:
    Problema con Render y textura UV -cycles_procesat.png

  6. #6
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    No me acordaba que querías poner el normal map...

    Perdona, pero el mapa de normales (Normal map) se coloca diferente que cuando es una textura de imagen normal.
    El mapa de normales se pone sin color (Non-color Data) y se enlaza al DISPLACEMENT

    Problema con Render y textura UV -displace.jpg


  7. #7
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    http://www.pasteall.org/blend/23416

    Se pone un nodo INVERT por si quieres invertirlo.

  8. #8
    Senior Member Avatar de xmasb
    Fecha de ingreso
    Oct 2009
    Ubicación
    Castellon
    Mensajes
    144

    Re: Problema con Render y textura UV.

    Pues ya es más difícil ayudarte, sube el .blend si quieres y se mira a ver que pasa.

    ***edit**

    Soliman te contesto antes que yo, pero no se donde se dijo que querías poner el normal map
    Última edición por xmasb; 14-08-2013 a las 22:56

  9. #9
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    Por que ya viene de otro post donde estaba haciendo el sculpt y luego el normal map.
    Al ver la textura de color azul me he acordado....

  10. #10
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Cita Iniciado por Soliman Ver mensaje
    No me acordaba que querías poner el normal map...

    Perdona, pero el mapa de normales (Normal map) se coloca diferente que cuando es una textura de imagen normal.
    El mapa de normales se pone sin color (Non-color Data) y se enlaza al DISPLACEMENT

    Problema con Render y textura UV -displace.jpg
    Ahora lo he conseguido, pero queda mal.

    Si escalo el objeto al que le había creado un Normal map, haciendolo más grande. Quedará mal?

    Es que en el procesado queda mal, pero con el interno no.

  11. #11
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    Si tienes que escalar el objeto, se puede poner un Vector de tipo Mapping
    Pero para un UV no creo que te vaya bien, pues lo que hara, será duplicarte la imagen.

    Problema con Render y textura UV -vector.jpg

    Desde los valores de Location y Rotation del Vector Mapping, se puede mover la imagen. Pero ya te digo, si la tienes en UV esto no tiene sentido.

    Sube alguna imagen de como te queda el render.

  12. #12
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Cita Iniciado por Soliman Ver mensaje
    Si tienes que escalar el objeto, se puede poner un Vector de tipo Mapping
    Pero para un UV no creo que te vaya bien, pues lo que hara, será duplicarte la imagen.

    Problema con Render y textura UV -vector.jpg

    Desde los valores de Location y Rotation del Vector Mapping, se puede mover la imagen. Pero ya te digo, si la tienes en UV esto no tiene sentido.

    Sube alguna imagen de como te queda el render.
    He realizado un render para que veas como queda, parece desfigurado o movido:
    Problema con Render y textura UV -render_uv.png

    Aquí te dejo una captura de como debería quedar el render: Esta hecho con el interno de textura.
    Problema con Render y textura UV -render_uv1.png


    Aunque si no lo consigo, le dare este otro que queda si no bien curioso:
    Problema con Render y textura UV -porocesat.png
    Última edición por Nugu; 15-08-2013 a las 11:02

  13. #13
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Como se que es complicado de resolver, subo el archivo .blend con el objeto en cuestión.

    Pensaba que si borraba todo lo demás, pesaría menos. Pero aun así son 604 MB.
    Archivos adjuntados Archivos adjuntados

  14. #14
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,186

    Re: Problema con Render y textura UV.

    Pero no se supone que has hecho una retopología de esa malla con pocos vértices...?
    Mi portátil apenas lo puede abrir y si intento tocar algo se me bloquea.
    La malla son más de 2 millones de vértices.
    Y recuerda que si no empaquetas las texturas, en el blend que mandes no saldrán y no se podrá ver el detalle.

    Saludos y a ver si alguien lo puede manejar para ver el fallo.

  15. #15
    Senior Member Avatar de Nugu
    Fecha de ingreso
    Jul 2013
    Ubicación
    Vilanova del Camí (Barcelona)
    Mensajes
    626

    Re: Problema con Render y textura UV.

    Cita Iniciado por Soliman Ver mensaje
    Pero no se supone que has hecho una retopología de esa malla con pocos vértices...?
    Mi portátil apenas lo puede abrir y si intento tocar algo se me bloquea.
    La malla son más de 2 millones de vértices.
    Y recuerda que si no empaquetas las texturas, en el blend que mandes no saldrán y no se podrá ver el detalle.

    Saludos y a ver si alguien lo puede manejar para ver el fallo.
    Si que le apliqué, pero lo uní con la otra parte del objeto.

    Para poder empaquetar, hay que clicar en la F?

Página 1 de 2 12 ÚltimoÚltimo

Temas similares

  1. 3ds Max Vibracion de textura en el render
    Por Egrodnersaj en el foro Render, Iluminación y Cámaras
    Respuestas: 4
    Último mensaje: 29-07-2016, 11:45
  2. Problema con textura en render vray
    Por elvascko en el foro Render, Iluminación y Cámaras
    Respuestas: 0
    Último mensaje: 15-07-2010, 05:28
  3. Maya Problema Render y textura
    Por erichigienic en el foro Render, Iluminación y Cámaras
    Respuestas: 1
    Último mensaje: 26-02-2010, 10:53
  4. Blender Desenfoque textura en render
    Por Blanch en el foro Materiales y Texturizado
    Respuestas: 2
    Último mensaje: 17-09-2009, 18:23
  5. 3ds Max De render a textura alámbrica
    Por yeray en el foro Materiales y Texturizado
    Respuestas: 1
    Último mensaje: 09-09-2003, 07:53

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •