Gracias Gracias:  0
Resultados 1 al 6 de 6

Tema: No me funciona el x-mirror en una armadura

  1. #1
    Miembro Avatar de mayid
    Fecha de ingreso
    Feb 2010
    Ubicación
    BsAs
    Mensajes
    60

    No me funciona el x-mirror en una armadura

    Tengo hecha una armadura siguiendo los pasos de este tutorial:
    http://wiki.blender.org/index.php/Do..._body_armature

    Ahí se enseña a hacer huesos simétricos apretando shift+e. Con esto uno hace el hueso del brazo izquierdo y derecho a la vez, por ejemplo.

    La primera vez que seguí el tutorial todo fue bien. Buscando las equivalencias entre la versión 2.49 que usa el tutorial y el Blender 2.5 que uso yo.

    El problema ahora es que no puedo hacer un weight painting de una armadura de forma que al pintar el brazo derecho también se pinte el lado izquierdo. Tengo la casilla x-mirror marcada, pero no funciona.

    Dejo el archivo por si quieren chequearlo. Gracias por cualquier comentario que puedan hacer para llegar a una solución:
    http://www.aoi-castellano.com.ar/img...nimate14.blend

  2. #2
    Senior Member Avatar de Daniel Romero
    Fecha de ingreso
    Aug 2009
    Ubicación
    barranquilla-colombia
    Mensajes
    167

    Respuesta: No me funciona el x-mirror en una armadura

    amigo mio primero que todo el al hueso no se le puede aplicar el weight painting ya que no esta formado por vértices, el weight painting solo se aplica en las mallas.
    para aplicar esta lo mejor seria eliminar la mitad de los vértices verticalmente y agragar una propiedad de miror así que al aplicar cualquier función esta lo hará de forma cimetrica ah y otra cosa el x- miror solo aplica sobre el armature
    Solo cuando cumples tus objetivos Logras ser el Mejor

    "lo he dicho yo"

  3. #3
    Miembro Avatar de mayid
    Fecha de ingreso
    Feb 2010
    Ubicación
    BsAs
    Mensajes
    60

    Respuesta: No me funciona el x-mirror en una armadura

    Gracias por comentar. Es lógico lo que decís, de que se pinta la malla y no los huesos, entonces habría que espejar la malla. Pero estoy en duda porque durante el tutorial veníamos usando un omdificador de tipo espejo, que a la hora de dar lugar a la armadura tenía que ser aplicado. Es decir, roto. Mira:
    http://wiki.blender.org/index.php/Do..._body_armature

    "The Mirror modifier created virtual vértices on the other side of the mesh, and before we can attach an armature to the mesh we need to make those vértices real."

    Vos usas este método, de mallas espejadas para aplicar encima una armadura? Seguro?

    >> y otra cosa el x- miror solo aplica sobre el armature

    Sobre esto me quedo pensando. Pero busqué y busqué y no encuentro falla.

    Te comento que la primera vez que hice el tutorial todo fue bien. Hice el muñequito que se propone. Pero ahora quiero aprovechar el método para animar un personaje propio.

    Gracias!

  4. #4
    Miembro Avatar de mayid
    Fecha de ingreso
    Feb 2010
    Ubicación
    BsAs
    Mensajes
    60

    Respuesta: No me funciona el x-mirror en una armadura

    Solucionado! Lo que hice fue exportar de nuevo mi modelo original desde Art of Illusion, pero bien centrado y rotado, de manera de que no tuviese que hacer ningún cambio desde Blender. Y todo funciona ok ahora.

  5. #5
    Senior Member Avatar de Daniel Romero
    Fecha de ingreso
    Aug 2009
    Ubicación
    barranquilla-colombia
    Mensajes
    167

    Respuesta: No me funciona el x-mirror en una armadura

    Cita Iniciado por mayid Ver mensaje

    Vos usas este método, de mallas espejadas para aplicar encima una armadura? Seguro?

    Gracias!
    si y no me has entendido "creo" mira en el blender 2.49 en panel de malla F9 en modifiers aplicale el efecto miror a la malla pulsa el botón de dip clipping para que los vértices del centro no se muevan una vez hecho esto hazlo hijo de el armature y pinta los vértices luego que ya no pretendas seguir el modelado aplica el modificador de espejo(miror modifier) y el rig estará terminado e igual de ambos perfiles de la en el 2.5 debe funcionar igual
    Solo cuando cumples tus objetivos Logras ser el Mejor

    "lo he dicho yo"

  6. #6
    Miembro Avatar de mayid
    Fecha de ingreso
    Feb 2010
    Ubicación
    BsAs
    Mensajes
    60

    Respuesta: No me funciona el x-mirror en una armadura

    Ah! Si. Ahora entiendo. Se trabaja solo en una mitad, y al aplicar el espejo queda el modelo entero. Ok, gracias.

Temas similares

  1. el mirror mode de skin me funciona mal D:
    Por willow89 en el foro Animación y Rigging
    Respuestas: 0
    Último mensaje: 05-08-2013, 01:18
  2. Blender Mirror Shape key funciona
    Por Slash148 en el foro Modelado
    Respuestas: 1
    Último mensaje: 12-09-2011, 19:29
  3. armadura
    Por viktorsnf en el foro Trabajos en Proceso
    Respuestas: 2
    Último mensaje: 26-07-2011, 17:02
  4. armadura
    Por 3DPregunton en el foro Modelado
    Respuestas: 3
    Último mensaje: 11-08-2008, 21:08
  5. ray mirror no me funciona
    Por giorgiomartini en el foro Render, Iluminación y Cámaras
    Respuestas: 0
    Último mensaje: 13-03-2007, 16:02

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •