Gracias Gracias:  0
Resultados 1 al 9 de 9

Tema: problemas al animar

  1. #1
    Miembro Nuevo
    Fecha de ingreso
    Dec 2014
    Mensajes
    4

    problemas al animar

    Hola a todos, tengo un problema al tratar de animar a mi personaje, lo que pasa es que la ropa se desgarra en modo T la ropa esta perfectamente en su lugar pero cuando lo pongo en modo pose y le empiezo a mover, la ropa se desgarra y muestra partes del cuerpo. como le hago para que la ropa siga sobre el cuerpo y no pase eso?.

    Ejemplo la fotografía.

    problemas al animar-sin-titulo.jpg

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,199

    Re: problemas al animar

    Pero a la tela de los pantalones le tienes puesto algún modificador (tipo Shrinkwarp) o físicas como Cloth?.

    Mi recomendación es que todo el cuerpo del modelo no se ve, lo borres y que solo tengas un objeto sin duplicidad de vértices.

  3. #3
    Miembro Nuevo
    Fecha de ingreso
    Dec 2014
    Mensajes
    4

    Re: problemas al animar

    No entiendo que es eso de los modificadores.

  4. #4
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,199

    Blender Re: problemas al animar

    Pues entonces vamos mal, pues si no sabes que son los modificadores, menos sabrás de los grupos de vértices.
    Si quieres subir el blend para que lo mire....
    http://www.pasteall.org/blend/
    Seleccionas y cargas el BLEND... esperas unos segundo y en la barra de direcciones saldrán unos números al final.
    Copias esa nueva dirección y la pegas aquí.

  5. #5
    Miembro Nuevo
    Fecha de ingreso
    Dec 2014
    Mensajes
    4

    Re: problemas al animar

    Se de los vértices, pues de ahí cree los la "ropa" pero eso " (tipo Shrinkwarp) o físicas como Cloth'', eso no le entiendo, pero no hay alguna opción para que la ropa no sobre pase?.

  6. #6
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,199

    Re: problemas al animar

    Si no das más "pistas" dificilmente te podremos ayudar.
    Así a simple vista de la imagen que has puesto, diría que has hecho un movimiento muy rápido y que no le ha dado tiempo a calcular el movimiento de esos vértices...
    Sigues sin decirme si son objetos separados y si alguno de ellos (los pantalones) tienes Physics (o sea CLOTH) y en ese caso, si la pierna tiene COLLISION.

  7. #7
    Miembro Nuevo
    Fecha de ingreso
    Dec 2014
    Mensajes
    4

    Re: problemas al animar

    Okay a ver, son ropa, tienen vértices separados pero los huesos los detectan como la pierna. osea si muevo la pierna se mueve el pantalón así como la sudadera.
    el modelo del cuerpo es uno solo, pantalón, sudadera, zapato etc, son cada uno con sus vértices, pero están detectados para que estén unidos y cuando muevo por ejemplo la pierna como que se traspasa la pierna del pantalón y así también con los brazos la sudadera etc.

  8. #8
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,199

    Re: problemas al animar

    Si dices que es ropa (PHYSICS Clouth) puedes hacer un pinning, que sería ponerle un grupo de vértices por la zonas donde se te destroza al mover la pierna, para así conseguir que "tire" mejor de la ropa y a la vez quede ajustada a esas zonas (como puede ser la rodilla o el tobillo.

    Si sabes poner vertex groups, solo tienes que poner uno nuevo y seleccionas... (por ejemplo)... la cintura, la parte de las rodillas o muslos y el tobillo.
    Luego activas en CLOTH el pinning y pones el nombre del grupo de vértices.

    problemas al animar-pinning1.jpg problemas al animar-pinning2.jpg

  9. #9
    Miembro Nuevo
    Fecha de ingreso
    Dec 2014
    Ubicación
    Tenerife
    Mensajes
    22

    Re: problemas al animar

    Buenas, una pregunta, ¿has marcado algo para que la ropa sea calculada por Blender como "tela" con física? ¿o la ropa del modelo es un objeto igual que la pierna que sobrepasa?

    Disculpen que pregunte pero no lo tengo claro. No suelo animar con "tela" así que en caso afirmativo no te podría ayudar.

    Sigo escribiendo pensando que no has usado "tela" con físicas.
    Por la imagen y lo que comentas me parece más un problema de pintado de pesos de los vértices (lo podrías arreglar relativamente fácil).

    Pero más fácil aún, lo primero que decía Soliman, si la pierna del personaje no se va a ver, lo mejor es borrarla. Lo mismo con el resto de partes del cuerpo ocultas por la ropa.
    En 3d se trabaja así. No hay cuerpo bajo la ropa!

Temas similares

  1. Blender Problemas al animar en Blender
    Por Addiel en el foro Problemas con Programas
    Respuestas: 1
    Último mensaje: 06-07-2016, 14:20
  2. Blender Problemas BG, animar armature
    Por Gabriel_Arg en el foro Problemas con Programas
    Respuestas: 8
    Último mensaje: 12-12-2012, 10:34
  3. problemas animar sin biped
    Por renoir en el foro Animación y Rigging
    Respuestas: 3
    Último mensaje: 01-02-2009, 22:52
  4. problemas de iluminacion al animar con v-ray
    Por Pekeño Saltamontes en el foro Render, Iluminación y Cámaras
    Respuestas: 2
    Último mensaje: 26-08-2005, 15:21
  5. problemas con animar en red
    Por primus67 en el foro Animación y Rigging
    Respuestas: 3
    Último mensaje: 22-07-2005, 23:01

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •