Gracias Gracias:  0
Resultados 1 al 7 de 7

Tema: Se me desmonta la animacion

  1. #1
    M.M.D.D. Avatar de Faust
    Fecha de ingreso
    Sep 2010
    Ubicación
    Sevilla
    Mensajes
    16

    Se me desmonta la animación

    Hola a todos
    He empezado hace muy poco con el modelado en 3D y estoy bajandome tutoriales y documentación.
    Actualmente estoy probando cosas, como el modificador "Rigged Body Collection". Para concretar, he creado una mesa de billar con cuatro bolas. La idea es que una bola (roja) golpee al resto, y se desplacen por la mesa. Le he asignado un modificador a la bola que golpea, a las tres golpeadas y a la mesa. He establecido el peso, la elasticidad de cada uno, etc...
    Creo la animación con el reactor, y cuando la bola golpea a las otras ... se me cae todo al "suelo"
    Sé que estoy haciendo algo mal pero no sé que es lo que es.

    ¿Me podéis ayudar?

  2. #2
    reconvertido Avatar de ikerCLoN
    Fecha de ingreso
    Apr 2002
    Ubicación
    Los Angeles, USA
    Mensajes
    14,911

    Re: Se me desmonta la animación

    Es decir, supongo que las 'bolas' atraviesan la mesa, ¿no? Revisa que la mesa, o la superfície donde se deslizan las bolas, sea una caja y no un plano. En ocasiones esto último puede darte problemas. Chequea también que la 'distancia de tolerancia' sea la correcta, y que todo el sistema esta construido a una escala más o menos 'correcta' (el tener esferas de 20 metros de diametro en lugar de 20 centímetros puede ser también origen de incidencias).
    character TD @ Walt Disney Animation Studios

    mi curso de rigging facial :: https://www.domestika.org/en/courses...je-3d/ikerclon
    blog :: www.somosposmodernos.com
    twitter :: www.twitter.com/soyposmoderno
    linkedIn :: www.linkedin.com/in/ikerj

  3. #3
    Miembro Nuevo
    Fecha de ingreso
    Jun 2010
    Mensajes
    21

    Re: Se me desmonta la animación

    activa la casilla convave mesh... (se encuentra en donde le pones peso a un objeto y esas cosas)
    y ve que las bolas no atraviesen la mesa antes de comensar la animacion
    pruebalo y suerte

  4. #4
    M.M.D.D. Avatar de Faust
    Fecha de ingreso
    Sep 2010
    Ubicación
    Sevilla
    Mensajes
    16

    Re: Se me desmonta la animación

    Efectivamente, cuando las bolas chocan atraviesan la mesa y caen, pero esta también cae. La mesa la hice con un box al que le quité el centro con otro box y una sustración booleana. No he revisado la distancia de tolerancia. Le echaré un vistazo porque seguramente sea eso.
    Muchas gracias por la ayuda.

  5. #5
    M.M.D.D. Avatar de Faust
    Fecha de ingreso
    Sep 2010
    Ubicación
    Sevilla
    Mensajes
    16

    Re: Se me desmonta la animación

    Muchas gracias, lo pruebo y te digo.

  6. #6
    Miembro Nuevo
    Fecha de ingreso
    Jun 2010
    Mensajes
    21

    Re: Se me desmonta la animación

    otra cosa..asegurate de que la mesa no tenga peso
    y después todo lo mismo xD

  7. #7
    M.M.D.D. Avatar de Faust
    Fecha de ingreso
    Sep 2010
    Ubicación
    Sevilla
    Mensajes
    16

    Re: Se me desmonta la animación

    Cita Iniciado por luis8p Ver mensaje
    otra cosa..asegurate de que la mesa no tenga peso
    y después todo lo mismo xD
    Muchas gracias.
    Parece ser que el problema estaba en que la bola estaba dentro de la mesa. Al hacer la sustración, le dejé bordes y cuando analizaba me informaba que la bola estaba "dentro" de la mesa. Reinice la escena, quitando los "bordes" y me funcionó a la perfección con los parámetros que me indicasteis.
    Gracias.

Temas similares

  1. Respuestas: 3
    Último mensaje: 18-07-2014, 19:40
  2. Respuestas: 0
    Último mensaje: 04-09-2013, 14:12
  3. Respuestas: 3
    Último mensaje: 28-09-2008, 09:52
  4. Probelma animacion de camara: animacion final con ligeros saltos
    Por ximy en el foro Animación y Rigging
    Respuestas: 0
    Último mensaje: 09-04-2008, 15:11
  5. Respuestas: 2
    Último mensaje: 20-07-2007, 00:32

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •