Gracias Gracias:  3
Resultados 1 al 12 de 12

Tema: Error en el suavizado de poligonos

  1. #1
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Error en el suavizado de polígonos

    Hola!
    Tengo un error en 3ds Max 2011 en el suavizado de un elemento. En este caso en particular es un ojo (pero me paso también en otro modelado...) que lo tengo que trabajar. Es exportado de otro programa (no se cual...) en un OBJ, quizás aquí esta el problema.
    El tema es que al aplicar el modficador Turbosmooth se me suaviza la forma pero no al 100%...No lo hace bien en la zona de las aristas.
    Si le subo el valor del Turbosmooth el error no se va...
    Adjunto imágenes para que se entienda mejor.

    Error en el suavizado de poligonos-imagen-error-01.jpg

    Error en el suavizado de poligonos-imagen-error-02.jpg

    Error en el suavizado de poligonos-imagen-error-03.jpg

    Si alguien sabe alguna solución se la agradecería mucho!
    Gracias!
    Última edición por teblopa; 13-01-2012 a las 23:13

  2. #2
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950

    Re: Error en el suavizado de polígonos

    Eso ocurre porque justo donde se marcan esas aristas hay más de un edge. Compruébalo.

    Saludos!

  3. #3
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Limon 3DPoder Re: Error en el suavizado de polígonos

    Reihzard, muchas gracias por escribir!
    Pero lamentablemente no, no hay varios edges...
    Adjunto dos imágenes de cuando seleccione un edge y lo movi de lugar.

    Error en el suavizado de poligonos-imagen-error-04.jpg

    Error en el suavizado de poligonos-imagen-error-05.jpg

    Se les ocurre otra posible solucion?
    Muchas gracias!

  4. #4
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950

    Re: Error en el suavizado de polígonos

    ¿Puedes subir ese .obj para ver qué ocurre? De todas formas, ese ojo no es nada complejo de hacer.
    Supongo que igual lo has utilizado por la textura del iris... pero mapear eso tampoco tiene complicación alguna.

    Saludos!

  5. #5
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Re: Error en el suavizado de polígonos

    Reihzard!
    Gracias por interesarte!
    Mira este error me pasa también en una forma más compleja ( en un pelo de un personaje...)
    Subi el error en el OJO para que se vea mejor. El ojo lo hago de nuevo, con el pelo se me complica...
    Subo el archivo MAX y un OBJ.
    Fijate a ver si ves algo extraño.
    Muchas Gracias!
    Archivos adjuntados Archivos adjuntados

  6. #6
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950

    Re: Error en el suavizado de polígonos

    Pues no veo nada raro... ni en el objeto ni en el render. A mí no me aparecen esas aristas que has puesto en las imágenes. Solo he podido abrir el .obj ya que solo trabajo con max2009.

    De todas formas te envío un archivo .max con 3 ojos: el de la izquierda sin smooth, el del medio con smooth a 1, y el de la derecha con 2, a ver si sigues viendo ese problema.

    Saludos
    Archivos adjuntados Archivos adjuntados

  7. #7
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Re: Error en el suavizado de polígonos

    Reihzard!
    Mira...abri el tu OBJ y lo veo perfecto.
    Abro mi OBJ (el que adjunte al foro) y lo veo con el mismo error (es mas...creo que se ve peor...).
    Te adjunto la imagen:

    Error en el suavizado de poligonos-imagen-error-06.jpg

    Tendré algún error de seteo/visualización en el 3ds max 2012?
    El problema es que es un error difícil de buscar en la red...
    Muchas gracias por tu ayuda!

  8. #8
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950

    Re: Error en el suavizado de polígonos

    Pues tiene toda a pinta de ser un problema de max 2012. Prueba a utiliar el ojo del archivo que te he pasado; lo seteas igual y le añades los materiales del ojo "malo" y ya esta.

    Saludos

  9. #9
    Miembro Avatar de JLM
    Fecha de ingreso
    Feb 2007
    Ubicación
    León
    Mensajes
    51

    Re: Error en el suavizado de polígonos

    Hola,

    Yo que ando también trasteando con el MAX 2012 pero el Design en mi caso, he tenido veces en que al importar .obj, me ha pasado lo mismo. Lo que he hecho ha sido utilizar la opción "Auto Smooth" a 30.0, en vez de aceptar "Import from file", esto combinado con un "Turbosmooth" a 1 iteración es más que suficiente en la mayoría de los casos.

    Un saludo!
    Miniaturas adjuntadas Miniaturas adjuntadas Error en el suavizado de poligonos-prueba.jpg  

  10. #10
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Re: Error en el suavizado de polígonos

    Reihzard!
    Hay algo que se rompe al importar los OBJs del modelo que tengo que usar al 3ds Max 2011 (es la versión que uso...me equivoque en la versión que dije más arriba).
    Acabo de comprobar que todas las partes que me pasaron del modelo en OBJ tienen este problema.
    Adjunto dos imágenes de las manos...

    La primera es el OBJ que me dieron, que es un HighPoly sin el turbosmooth...

    Error en el suavizado de poligonos-mano-error-01.jpg

    La segunda es cuando le aplico Turbosmooth...ahí se ve el error. (No me equivoque al subir las imágenes!)

    Error en el suavizado de poligonos-mano-error-02.jpg

    En esta parte del cuerpo la puedo usar sin el suavizado...pero hay otras que no, que necesito usar el turbosmooth si o si.
    Tendria que importar nuevamente los OBJs en otra versión de 3ds a ver si es eso...
    Veo de probarlo a ver que pasa!

    Si a alguien se le ocurre otra posible solucion...será bienvenida!!!

    Reihzard, muchas gracias por tu tiempo!

  11. #11
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950

    Re: Error en el suavizado de polígonos

    De nada. Sé que puede parecer una chorrada, pero has probado la opción Use nurms subdivisión de Editable Poly, sin usar el turbosmooth?
    Y probando con el meshsmooth en vez de turbosmooth?

    Prueba a ver si te da ese problema de esas dos formas.
    Un saludo

  12. #12
    Miembro Nuevo
    Fecha de ingreso
    Jan 2012
    Mensajes
    12

    Re: Error en el suavizado de polígonos

    JLM! Perdon, o no se actualizo tu post o me lo pase por alto!
    Mucha gracias por tu respuesta! Era eso nomas, tenias razón!
    Entendi el problema...El error estaba al importar el OBJ en el 3DS MAX, más precisamente con las oipciones de "NORMALS"...
    En el cuadro de opciones al importar un OBJ hay un apartado de NORMALS, adjunto una captura:

    Error en el suavizado de poligonos-import-obj.jpg

    Yo lo tenía tildado en la opción "Import from File" y es ahí donde me generaba ese error extraño en los vértices del los objetos.
    Cuando lo cambie a "Faceted", me lo importo faceteado y al agregar el modificador TURBOSMOOTH se suavizo sin problemas.

    Espero que este post le sirva a alguien que se encuentre con este mismo problema!
    Reihzard y JLM, muchas gracias por sus ayuda!

    Abrazo!
    Última edición por teblopa; 19-01-2012 a las 04:00

Temas similares

  1. Maya Suavizado
    Por DUZGO en el foro Modelado
    Respuestas: 9
    Último mensaje: 20-02-2009, 16:17
  2. suavizado
    Por dixan en el foro Modelado
    Respuestas: 4
    Último mensaje: 19-05-2006, 20:02
  3. suavizado
    Por Thule en el foro Problemas con Programas
    Respuestas: 1
    Último mensaje: 24-12-2004, 22:01
  4. Error al subdividir polígonos
    Por Fangface en el foro Modelado
    Respuestas: 3
    Último mensaje: 03-11-2004, 17:27
  5. suavizado
    Por andy_00 en el foro Modelado
    Respuestas: 2
    Último mensaje: 01-12-2003, 20:22

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •