Gracias Gracias:  3
Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 15 de 30

Tema: Error siguiendo un tutorial

  1. #1
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Error siguiendo un tutorial

    ¡Hola!

    Estoy intentando seguir un mini tutorial de Reynante Martínez: http://www.reynantemartinez.com/how-...gle-image.html.

    He comenzado creando una escena y la esfera y siguiendo los pasos del tutorial crear el material. No ha funcionado correctamente.

    Así que he descargado los ficheros Blend que adjunta en el tutorial, y he creado una copia del "Finished .blend file". He adjuntado una textura similar a la del tutorial y el resultado de la esfera creada por Reynante se ve perfecto.

    El caso es que he añadido una esfera al lado de la existente para recrear sobre dicha esfera nueva, un material que "copie" paso a paso el creado por Reynante. Por si acaso, a esta esfera nueva, la de la derecha, le he asignado el mismo material ya creado para asegurarme que funciona igual.

    Pues no. No funciona igual. cada esfera tiene un mapeado diferente. ¿Por qué? ni idea. He comparado la geometría de ambas esferas y no consigo encontrar el punto en el que se define cómo se aplica la textura.

    ¿Alguien sabe por qué pasa esto?

    He usado Blender 2.79.

    Un saludo.
    Miniaturas adjuntadas Miniaturas adjuntadas Error siguiendo un tutorial-prueba-2.png  
    Archivos adjuntados Archivos adjuntados

  2. #2
    Usuario completo Avatar de Vic3D
    Fecha de ingreso
    Oct 2014
    Mensajes
    533

    Re: Error siguiendo un tutorial

    No puedo ver el desplegado de la malla en el archivo que adjuntas (al selecionar las caras en edit mode debería aparecer el desplegado en el UV/Image Editor), ni escalar, rotar, et, c. que es lo que tendrías que hacer para que quedara igual. Lo único que veo es que en la esfera de Reynante hay un lop marcado con Mark Seam (control + E) y en la tuya no, aunque aparte de eso tendrías que escalar y rotar la textura como digo..

    PD: Vale, ya veo el desplegado de la malla. Tienes que borrar la pestañita de "Render Result" para que te aparezca, ahí ya podrás rotar y escalar para que quede a tu gusto (haciendo un Unwrap primero con "U", o puedes probar con los diferentes modos que hay)..

    Salu2
    Blender nuestro que estás en el disco duro, santificado sea tu nombre. Venga a nosotros tu código abierto. Hágase tu voluntad, asi en el render como en la preview. Danos hoy el addon de cada día y perdona nuestros control Z, asi como nosotros perdonamos algunos blueprints. No nos dejes caer en otro software, más libranos del lag. Amén.

    Artstation // Behance

  3. #3
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    ¡Hola!

    Acabo de marcar un Lop como Seam en la esfera de la derecha, y el resultado no varía.

    Si selecciono la esfera original, la de la izquierda, y entro en modo Edit, en la ventana de UV/Image Editor, tampoco aparece su malla desplegada. Es como si Reynante no hubiese realizado ningún desplegado. O, por lo menos yo no soy capaz de verlo. Es decir ¿Dónde están los parámetros o desplegado que le dice al material cómo debe colocarse sobre la esfera de la izquierda?

    Un saludo.

  4. #4
    Usuario completo Avatar de Vic3D
    Fecha de ingreso
    Oct 2014
    Mensajes
    533

    Re: Error siguiendo un tutorial

    Tienes que quitar la pestañita de "Render Result", entonces ya aparece. Así es como me sale a mí la de Reynante (o como tendrías que tenerla en la otra esfera para que la textura te salga igual).

    Error siguiendo un tutorial-prueba2.jpg

    Salu2
    Blender nuestro que estás en el disco duro, santificado sea tu nombre. Venga a nosotros tu código abierto. Hágase tu voluntad, asi en el render como en la preview. Danos hoy el addon de cada día y perdona nuestros control Z, asi como nosotros perdonamos algunos blueprints. No nos dejes caer en otro software, más libranos del lag. Amén.

    Artstation // Behance

  5. #5
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    Vale, y ¿dónde está la dichosa pestañita de Render Result? ¿En la ventana del UV / Image Editor?

    Perdona, pero es que no la veo.
    Miniaturas adjuntadas Miniaturas adjuntadas Error siguiendo un tutorial-captura-1.png  

  6. #6
    Usuario Senior
    Fecha de ingreso
    May 2016
    Ubicación
    Valencia
    Mensajes
    146

    Re: Error siguiendo un tutorial

    Necesitas desplegar las UV de tu esfera. Para eso puedes seleccionar las caras de tu esfera en edit mode y pulsar U para abrir el menu de unwrap. Luego de la lista seleccione Sphere Projection, y desde el UV editor rotas el la malla desplegada 90º para que las maderas vayan en horizontal en vez de en vertical. Si no sabes lo que son las UV, el unwrap, te recomiendo que te mires algún tutorial sobre UV o texturizado en Blender que explique como desplegar una malla.

  7. #7
    Usuario completo Avatar de Vic3D
    Fecha de ingreso
    Oct 2014
    Mensajes
    533

    Re: Error siguiendo un tutorial

    Pues la de "untitled" en tu caso (a mi me salía "render result" xD)

    Salu2
    Blender nuestro que estás en el disco duro, santificado sea tu nombre. Venga a nosotros tu código abierto. Hágase tu voluntad, asi en el render como en la preview. Danos hoy el addon de cada día y perdona nuestros control Z, asi como nosotros perdonamos algunos blueprints. No nos dejes caer en otro software, más libranos del lag. Amén.

    Artstation // Behance

  8. #8
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    A ver, si el tema de desplegar malla no me preocupa, sé hacerlo, creo. y también marcar costuras.

    El tema es ¿por qué no puedo ver la malla desplegada de la esfera creada por Reynante? Es como si Reynante hubiese creado la esfera para, a continuación, asignarle el material, y este, el material, se hubiese proyectado correctamente sobre la esfera. Además, en la estructura de nodos, no veo por ningún lado algún nodo referente a mapeado, UV's, Texture Cordinate, etc.

    Un saludo.

  9. #9
    Usuario completo Avatar de Vic3D
    Fecha de ingreso
    Oct 2014
    Mensajes
    533

    Re: Error siguiendo un tutorial

    Borra la pestañita que te salga debajo en el UV/Image editor (en tu caso "untitled") y luego pulsa U (con todas las caras de la esfera selecciónadas) y elige el modo de desplegado que quieras, te tiene que salir así.

    PD: Para la esfera de Reynante no hace falta pulsar U, ya que ya tiene la malla desplegada (sólo tienes que borrar la pestañita y seleccionar las caras)

    Salu2
    Blender nuestro que estás en el disco duro, santificado sea tu nombre. Venga a nosotros tu código abierto. Hágase tu voluntad, asi en el render como en la preview. Danos hoy el addon de cada día y perdona nuestros control Z, asi como nosotros perdonamos algunos blueprints. No nos dejes caer en otro software, más libranos del lag. Amén.

    Artstation // Behance

  10. #10
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    A ver. En todos los objetos que abro en Blender y tienen su desplegado hecho, cuando los selecciono y entro en el entorno "Edit"y selecciono los vértices o aristas o caras, aparece la malla desplegada en el UV/ Image Editor. En este caso, selecciono dichos elementos en el modo "Edit" y no aparece ninguna malla, por lo que entiendo que a esta esfera no se le ha aplicado ningún proceso de "UWnrap" o como se diga.

    Ya sé que si selecciono mi malla, la que he creado yo, y aplico un desplegado, aparecerá la malla y podré ajustar la posición y tamaño de la textura, pero ¿por qué no hace falta hacer esto mismo en la malla creada por Reynante?

    ¿Qué es lo que se me escapa?

  11. #11
    Usuario completo Avatar de Vic3D
    Fecha de ingreso
    Oct 2014
    Mensajes
    533

    Re: Error siguiendo un tutorial

    Has borrado la pestañita de untitled? Desplegado sí que tiene, vaya a mi me sale XD

    Salu2
    Blender nuestro que estás en el disco duro, santificado sea tu nombre. Venga a nosotros tu código abierto. Hágase tu voluntad, asi en el render como en la preview. Danos hoy el addon de cada día y perdona nuestros control Z, asi como nosotros perdonamos algunos blueprints. No nos dejes caer en otro software, más libranos del lag. Amén.

    Artstation // Behance

  12. #12
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    Vale. Ya está.

    No se trataba de borrar el Render Result o Untitled, de hecho, el nombre Untitled apareció cuando borré el nombre Render Result. Se trataba de seleccionar alguna imágen que no fuese Render Result.

    Gracias.

    Ahora el tema es conseguir desplegar la malla de la esfera, para que quede como la de Reynante, rectangular. Por lo pronto no hay manera.
    Última edición por Cayo; 17-12-2018 a las 19:12 Razón: Añadir texto

  13. #13
    Usuario Senior
    Fecha de ingreso
    May 2016
    Ubicación
    Valencia
    Mensajes
    146

    Re: Error siguiendo un tutorial

    Cita Iniciado por Cayo Ver mensaje
    A ver. En todos los objetos que abro en Blender y tienen su desplegado hecho, cuando los selecciono y entro en el entorno "Edit"y selecciono los vértices o aristas o caras, aparece la malla desplegada en el UV/ Image Editor. En este caso, selecciono dichos elementos en el modo "Edit" y no aparece ninguna malla, por lo que entiendo que a esta esfera no se le ha aplicado ningún proceso de "UWnrap" o como se diga.

    Ya sé que si selecciono mi malla, la que he creado yo, y aplico un desplegado, aparecerá la malla y podré ajustar la posición y tamaño de la textura, pero ¿por qué no hace falta hacer esto mismo en la malla creada por Reynante?

    ¿Qué es lo que se me escapa?
    Reynante también tuvo que hacer eso mismo en su esfera, solo que no lo nombra en el tutorial. Además, la esfera que pone de ejemplo no es una esfera en sí (los vertices superiores e inferiores no están unidos, si intentas seleccionar el vértice superior y lo mueves lo verás)
    También puedes, en el momento de crear la esfera, en el cuadro de diálogo en el que seleccione la cantidad de divisiones si queres que te la cree con UV o sin ellas, por defecto viene desactivado.

  14. #14
    Usuario Senior
    Fecha de ingreso
    May 2016
    Ubicación
    Valencia
    Mensajes
    146

    Re: Error siguiendo un tutorial

    Cita Iniciado por Cayo Ver mensaje
    Vale. Ya está.

    No se trataba de borrar el Render Result o Untitled, de hecho, el nombre Untitled apareció cuando borré el nombre Render Result. Se trataba de seleccionar alguna imágen que no fuese Render Result.

    Gracias.

    Ahora el tema es conseguir desplegar la malla de la esfera, para que quede como la de Reynante, rectangular. Por lo pronto no hay manera.
    Si activas generate UVs en el momento de crear la esfera (en el menú donde eliges las divisiones al crear objetos y demás) te saldrá algo bastante similar, pero como te he dicho, lo de Reynante no es una esfera propiamente, por lo que no te puede salir igual a no ser que la modifiques.

  15. #15
    Usuario Avanzado Avatar de Cayo
    Fecha de ingreso
    Mar 2009
    Mensajes
    321

    Re: Error siguiendo un tutorial

    ¡Vaya tela! el "polo Norte" y el "Polo Sur" tienen cada uno 16 vértices superpuestos. Jamás se me hubiese ocurrido pensar que había más de un vértice superpuesto.

    Si, acabo de probar el tema de la creación de la esfera y aparece un desplegado que se parece mucho.

    Esto me pasa por que no suelo modelar con Blender y se me escapan un montón de conceptos.

    En fin, paciencia. Ya iré aprendiendo poco a poco.

    ¡Gracias chicos!

Página 1 de 2 12 ÚltimoÚltimo

Temas similares

  1. Blender Movimiento siguiendo una trayectoria
    Por salinas69 en el foro Animación y Rigging
    Respuestas: 17
    : 29-10-2014, 21:21
  2. Maya Hijo no siguiendo a padre
    Por MAYAMAN en el foro Animación y Rigging
    Respuestas: 5
    : 06-06-2014, 03:55
  3. Resultado de un tutorial siguiendo los valores,de temperatura
    Por facun2 en el foro Render, Iluminación y Cámaras
    Respuestas: 3
    : 06-03-2010, 19:55
  4. Siguiendo consejos
    Por andresmerien en el foro Trabajos en Proceso
    Respuestas: 2
    : 11-05-2008, 01:50
  5. Siguiendo con lwf
    Por Diego-Design en el foro Trabajos Finalizados
    Respuestas: 12
    : 06-05-2008, 11:29

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •