Gracias Gracias:  1
Resultados 1 al 6 de 6

Tema: No se visualiza el modelo en el game engine

  1. #1
    Miembro Nuevo
    Fecha de ingreso
    Jan 2014
    Mensajes
    3

    No se visualiza el modelo en el game engine

    Buenas tarde usuarios necesito algo de ayuda aquí con blender, verán he hecho un modelo siguiendo un tutorial y bien el modelo quedo bien y lo quiero pasar al game engine y perfecto se ve el modelo, pero cuando en una parte del tutorial pasamos a hacer la textura directamente por blender y lo paso a modo UV de acuerdo como dice el tutorial resulta que cuando pongo el game engine el modelo no aparece y buscando e descubierto que cuando quito el UV map de la propiedades del objeto en la sección de object data el modelo vuelve a aparecer, que me falta o que opción no me ha salido en el tutorial para que se aplique y se vea el modelo y la textura en el modo game engine.

  2. #2
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,193

    Re: No se visualiza el modelo en el game engine

    No creo que sea eso...(si he entendido bien).
    Lo que puede pasar, es que a la hora de entrar en el Game a lo mejor no estas en modo de vista TEXTURE.

    No se visualiza el modelo en el game engine-camo.jpg

    También podría ser, que el objeto lo tuvieras con las caras invertidas (las caras traseras, por llamarlas de alguna forma) y esas caras traseras son transparentes por lo que no verías nada del objeto.
    Si es un problema de caras invertidas, solo selecciona el objeto en EDIT MODE y seleccionas todos los vértices y presionas Ctrl+N
    O mejor, haces que se puedan ver las dos caras en el GAME. Para eso vas a MATERIAL y desactiva Backface Culling

    No se visualiza el modelo en el game engine-camo2.jpg

  3. #3
    Miembro Nuevo
    Fecha de ingreso
    Jan 2014
    Mensajes
    3

    Re: No se visualiza el modelo en el game engine

    Acabo de hacer las dos cosas y nada simplemente no me aparece el modelo ni la textura, el problema se quita cuando elimine de las propiedades el UV creado y el modelo aparece pero sin textura, será que no lo he aplicado correctamente el UV sobre el modelo? en tal caso como lo aplicaría correctamente, si ayuda el UV lo he creado por blender al igual que la textura.

  4. #4
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,193

    Re: No se visualiza el modelo en el game engine

    Primero se crea el Material.
    Luego se crea la textura.
    Se le indica que es de tipo Image or Movie
    Se busca la imagen y abres un editor de UV/Image Editor
    Seleccionas el objeto en modo edición (Edit Mode)
    Seleccionas todos los vértices y presionas letra U > opción Unwrap (O la forma en que estés haciendo el uvmapeo).
    En la ventana UV/Image Editor ajustas la malla a la imagen
    En TEXTURE > Image te aseguras que la ruta de la imagen la tienes bien seleccionada.
    En Mapping Coordenates debes de seleccionar la opción UV
    En Map: el nombre de la UV que acabas de realizar (esto en realidad no afecta si solo tienes una textura UVMapeada).
    No se visualiza el modelo en el game engine-uv.jpg
    Y cuando vas a la pantalla principal para entrar en el Game asegúrate de estar en modo TEXTURE
    No se visualiza el modelo en el game engine-uv2.jpg
    Presionas letra P y tienes que entrar en el Game y ver la imagen igual.
    Prueba también a poner diferentes luces a la escena.
    En el panel de la derecha mira que tipo de Shading tienes puesto. Si GLSL o Multitexture.
    No se visualiza el modelo en el game engine-uv3.jpg

    Haz primero la prueba con un cubo o un plano para ver si estas realizando la secuencia bien.
    Y un tutorial o algo parecido de UV
    http://es.calameo.com/read/0005955792aef0da39816

  5. #5
    Senior Member Avatar de Soliman
    Fecha de ingreso
    Aug 2004
    Ubicación
    Torrevieja-Alicante
    Mensajes
    10,193

    Re: No se visualiza el modelo en el game engine

    Si sigue sin salirte, prueba a subir el blend, pero recuerda que la textura debe ir incluida, pues sin la textura a mi no me saldría nada.
    Para empaquetar la textura dentro del blend, solo tienes que pinchar sobre la caja que hay junto al nombre de la imagen.
    No se visualiza el modelo en el game engine-uv4.jpg
    O desde FILE > External Data > Pak .into blend file si tienes varias y lo quieres hacer todo de golpe.
    No se visualiza el modelo en el game engine-uv5.jpg

    Si quieres... hay una página para subir blends que dura unos 30 días la descarga activa en Pasteall http://www.pasteall.org/blend/
    Cargas el archivo blend, esperas a que en la barra superior cambie la dirección (te saldrá con unos números al final..) copias esa nueva dirección y la pegas en tu contestación.

  6. #6
    Miembro Nuevo
    Fecha de ingreso
    Jan 2014
    Mensajes
    3

    Re: No se visualiza el modelo en el game engine

    Gracias por todo logre hacerlo a tu manera y disculpa que no te respondiera antes tenía problemas de conexión con el Internet.

Temas similares

  1. Respuestas: 4
    Último mensaje: 05-04-2013, 14:00
  2. Game engine
    Por Metalyang en el foro Videojuegos
    Respuestas: 1
    Último mensaje: 27-05-2011, 15:14
  3. Blender El Game Engine
    Por 3dpoder en el foro Blender Art Magazine nº 6
    Respuestas: 0
    Último mensaje: 08-05-2009, 21:43
  4. Game Engine - Texto en el Game Engine - Tutorial
    Por 3dpoder en el foro Blender
    Respuestas: 1
    Último mensaje: 11-01-2009, 19:38
  5. Game engine
    Por PERIK en el foro Infografía General
    Respuestas: 11
    Último mensaje: 04-04-2007, 08:56

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •