Gracias Gracias:  2
Resultados 1 al 12 de 12

Tema: Problema con blend material

  1. #1
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Problema con blend material

    Hola gentes, tengo un asunto con el blender material de 3Ds Max que estoy perdiendo el tiempo a lo tonto.
    Lo estoy usando para tener a la vez un material que es un ojo y otro material con máscara que son los párpados, pero por algún motivo solo funciona orientado hacia arriba.
    Os paso 3 imágenes, como se ve en el render, como se ve en el visor y los materiales.
    Miniaturas adjuntadas Miniaturas adjuntadas Problema con blend material-cvv.jpg   Problema con blend material-anotacion-2019-11-14-203523.png   Problema con blend material-sdf.png  

  2. #2
    Usuario Avanzado
    Fecha de ingreso
    Feb 2005
    Mensajes
    274

    Re: Problema con blend material

    tienes coordenadas de mapeado?

  3. #3
    Sin dolor no hay ganancia Avatar de NeCRoManCeR
    Fecha de ingreso
    Jan 2005
    Ubicación
    Corrientes - Argentina
    Mensajes
    3,733

    Re: Problema con blend material

    Cita Iniciado por FrustratedZeus Ver mensaje
    Hola gentes, tengo un asunto con el blender material de 3Ds Max que estoy perdiendo el tiempo a lo tonto.
    Lo estoy usando para tener a la vez un material que es un ojo y otro material con máscara que son los párpados, pero por algún motivo solo funciona orientado hacia arriba.
    Os paso 3 imágenes, como se ve en el render, como se ve en el visor y los materiales.
    Tu segundo material no está resppondiendo a las coordenadas UVW, chequéa que el material de los párpados esté en otro canal que no sea el mismo que el del ojo.

  4. #4
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Re: Problema con blend material

    Cita Iniciado por Augusto3D Ver mensaje
    Tu segundo material no está resppondiendo a las coordenadas UVW, chequéa que el material de los párpados esté en otro canal que no sea el mismo que el del ojo.
    No se si te he entendido bien, si te refieres al material "verde principal", está en el blend porque tiene unos niveles especulares distintos al del globo. El modelo no tiene las UVW hechas, lo que intento conseguir es un solo material que incluya el globo y los párpados y aplicarlo solo a los polígonos que tienen la ID de ese material, y uso las máscaras para poder animarlos (te paso un archivo para que lo veas)
    Si no coloco el material de los párpados en el blend, dónde lo coloco?
    Archivos adjuntados Archivos adjuntados

  5. #5
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Re: Problema con blend material

    Cita Iniciado por quadro Ver mensaje
    tienes coordenadas de mapeado?
    No, solo uso un modificador UVW Map en modo planar y ajusto el gizmo. En el visor se ve que el gizmo deja el ojo en su sitio, pero cuando hago el render no. De hecho da igual cómo ponga el gizmo y en qué modo que en el render no se va a ver así
    Miniaturas adjuntadas Miniaturas adjuntadas Problema con blend material-anotacion-2019-11-15-150126.png  

  6. #6
    Sin dolor no hay ganancia Avatar de NeCRoManCeR
    Fecha de ingreso
    Jan 2005
    Ubicación
    Corrientes - Argentina
    Mensajes
    3,733

    Re: Problema con blend material

    Cita Iniciado por FrustratedZeus Ver mensaje
    No, solo uso un modificador UVW Map en modo planar y ajusto el gizmo. En el visor se ve que el gizmo deja el ojo en su sitio, pero cuando hago el render no. De hecho da igual cómo ponga el gizmo y en qué modo que en el render no se va a ver así
    Siendo que tu objeto es dinámico especulo muchas cosas. A la tarde, (en unas horas) abro el max y hago unas pruebas y te digo que me paarece bien. De todos modos yo haría Unwrap, a veces los materiales tan rebuscados dan fallos.


    Saludos.

  7. #7
    Sin dolor no hay ganancia Avatar de NeCRoManCeR
    Fecha de ingreso
    Jan 2005
    Ubicación
    Corrientes - Argentina
    Mensajes
    3,733

    Re: Problema con blend material

    Prueba cambiando el canal de tu mapa, que el ojo no esté en el mismo canal que el de párpado y si no pues bueno con el unwrap lo solucionas seguro.
    Problema con blend material-mapchannel.jpg

    Si no otra opción es agregar parámetros de animación a unos párpados de unos pocos polis y controlarlos con un helper. O hacer un Morph

  8. #8
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Re: Problema con blend material

    Cita Iniciado por Augusto3D Ver mensaje
    Prueba cambiando el canal de tu mapa, que el ojo no esté en el mismo canal que el de párpado y si no pues bueno con el unwrap lo solucionas seguro.
    Problema con blend material-mapchannel.jpg

    Si no otra opción es agregar parámetros de animación a unos párpados de unos pocos polis y controlarlos con un helper. O hacer un Morph
    Ha funcionado!!! Tenía tanto el ojo como los párpados en Planar from objet XYZ, los puse ahí ya ni me acuerdo por qué. Los he vuelto a poner todo a Explicit map channels y todo en orden!! Muchísimas gracias!!
    Miniaturas adjuntadas Miniaturas adjuntadas Problema con blend material-xvbz.jpg  

  9. #9
    Sin dolor no hay ganancia Avatar de NeCRoManCeR
    Fecha de ingreso
    Jan 2005
    Ubicación
    Corrientes - Argentina
    Mensajes
    3,733

    Re: Problema con blend material

    Cita Iniciado por FrustratedZeus Ver mensaje
    Ha funcionado!!! Tenía tanto el ojo como los párpados en Planar from objet XYZ, los puse ahí ya ni me acuerdo por qué. Los he vuelto a poner todo a Explicit map channels y todo en orden!! Muchísimas gracias!! Sigo teniendo un pequeño problema y es que cuando renderizo de lejos se ve una suciedad blanca, pero veré a ver si es por el png del iris o que
    Me alegra que te haya servido, ya me parecía que el UVW no estaba respondiendo bien por algo. Sobre la suciedad de tu ojo, prueba agregando subdivisión Turbosmooth ¿o es para una aplicación en tiempo real? pues si es así, en malla de polígono editable controla el suavizado de malla.
    Cuenta un poco más sobre este personaje, me da intriga. Es raro ver algo así jeje

  10. #10
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Re: Problema con blend material

    Cita Iniciado por Augusto3D Ver mensaje
    Me alegra que te haya servido, ya me parecía que el UVW no estaba respondiendo bien por algo. Sobre la suciedad de tu ojo, prueba agregando subdivisión Turbosmooth ¿o es para una aplicación en tiempo real? pues si es así, en malla de polígono editable controla el suavizado de malla.
    Cuenta un poco más sobre este personaje, me da intriga. Es raro ver algo así jeje
    Lo acabo de solucionar en un momento cambiando el png del iris por un color map con el iris como máscara. Ahora funciona a la perfección. LLevaba queriendo aprender a hacer este tipo de ojos mucho tiempo y verdaderamente no quería rendirme. Ahora por fin lo podré aplicar a cosas más chulas.

    Soy estudiante de animación 3D en Animum y furry, y estoy intentando ahorrar dinero para poder seguir estudiando, personajillo este es un encargo que me han hecho de una fursona. (Aquí paso algunos ejemplos) Y mientras los hago me gusta aprovechar para aprender a hacer cosas nuevas, especialmente de rigging, porque mi meta es tener la calidad suficiente como para que merezca la pena animar mis propios personajes. Se agradece el interés <3
    Miniaturas adjuntadas Miniaturas adjuntadas Problema con blend material-complex-background-and-illumination.png   Problema con blend material-half-body-2-.png   Problema con blend material-half-body.png   Problema con blend material-geo_render_final.png  

    Problema con blend material-little-animation.gif  
    Archivos adjuntados Archivos adjuntados

  11. #11
    Usuario Nuevo
    Fecha de ingreso
    Jul 2019
    Ubicación
    Murcia, España
    Mensajes
    11

    Re: Problema con blend material

    Una pregunta, habría algún modo de que el material blend se viera con las pestañas en el visor y no solo en el render? Sólo aparece el ojo y para animar va a estar mas complicado sin ver lo que hago

  12. #12
    Sin dolor no hay ganancia Avatar de NeCRoManCeR
    Fecha de ingreso
    Jan 2005
    Ubicación
    Corrientes - Argentina
    Mensajes
    3,733

    Re: Problema con blend material

    Cita Iniciado por FrustratedZeus Ver mensaje
    Una pregunta, habría algún modo de que el material blend se viera con las pestañas en el visor y no solo en el render? Sólo aparece el ojo y para animar va a estar mas complicado sin ver lo que hago
    Si no se ve con el botón de mostrar material en escena del apartado de materiales -M- desconozco si hay una opción que lo habilite. Creería que no.
    Prueba con el render de escenario quizás allí se muestre.

    Sobre tu tabajo, usar lowpolys con motores de render como Mental Ray puede ser interesante, ánimo con ello

    Saludos.

Temas similares

  1. Material vray blend mtl
    Por andreina en el foro Materiales y Texturizado
    Respuestas: 1
    : 21-10-2013, 05:23
  2. Problema con material blend
    Por rickardov en el foro Materiales y Texturizado
    Respuestas: 3
    : 24-10-2009, 19:24
  3. Maya Problema blend shapes
    Por Hulkong en el foro Animación y Rigging
    Respuestas: 5
    : 18-09-2009, 06:58
  4. Material blend Photoshop
    Por GABRIEL EM en el foro Materiales y Texturizado
    Respuestas: 1
    : 26-01-2007, 19:23
  5. Material blend con vray
    Por spline en el foro Materiales y Texturizado
    Respuestas: 5
    : 16-05-2005, 15:24

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •