Gracias Gracias:  0
Resultados 1 al 5 de 5

Tema: Problema con explode y pintura de peso

  1. #1
    Acólito Blenderita Avatar de MMalkavian
    Fecha de ingreso
    Jan 2008
    Mensajes
    182

    Blender Problema con explode y pintura de peso.

    Muy buenas, gurúes del ignoto mundo del diseño 3D.

    A ver si me podéis echar un cable con esto, que me pasé toda la tarde de ayer devanandome los sesos:

    Mi problema es simple. Aplico un modificador explode y un motor de partículas para que un objeto parezca descomponerse (bajando la vida de las partículas a 1 frame). Esto me funciona con formas simples.

    El problema viene cuando intento hacer lo mismo sobre un cono. Lo que quiero es que el cono empiece a descomponerse por la punta hasta finalmente hacerlo por la base. Es por ello que aplico pintura de peso a un grupo de vértices que posteriormente selecciono en el modificador explode.

    Lo que sucede entonces es que el cono empieza a descomponerse demasiado despacio (lógico, pues los polígonos son más pequeños a medida que nos acercamos al vértice). Sin embargo de repente para de descomponerse. Lo primeró en que me fijé fue el intervalo de frames que comprendía el motor de partículas (1-250) así que no había razón aparente para que frenara la descomposición en torno al 100.

    Pero ahí no terminan las complicaciones: Me gustaría que la velocidad de descomposición fuera constante en el espacio (desde el vértice hasta la base) sin importar polígonos implicados. ¿Es posible?

    Eso es todo. Perdón por el tocho y gracias anticipadas.

    Un Saludo.

  2. #2
    BlenderAdicto Avatar de Caronte
    Fecha de ingreso
    Dec 2004
    Ubicación
    Valencia-España
    Mensajes
    14,691

    Re: Problema con explode y pintura de peso.

    Si pones un .blend, es más fácil recibir ayuda
    "Algún día todo será digital". Caronte.
    Mi web: NicoDigital.com

  3. #3
    Acólito Blenderita Avatar de MMalkavian
    Fecha de ingreso
    Jan 2008
    Mensajes
    182

    Re: Problema con explode y pintura de peso.

    Perdón por no poner antes el .blend

    Era un inicio de proyecto y no lo había guardado.

    Aquí tengo el mismo problema aplicado al filo de una cimitarra que tenía por ahí.

    Un Saludo
    Archivos adjuntados Archivos adjuntados

  4. #4
    BlenderAdicto Avatar de Caronte
    Fecha de ingreso
    Dec 2004
    Ubicación
    Valencia-España
    Mensajes
    14,691

    Re: Problema con explode y pintura de peso.

    A ver...
    Que yo sepa, lo que pretendes hacer, no se puede hacer de ese modo

    Lo primero que te puedo decir es que estas usando un grupo de vértices en el campo para protegerlo (es decir para que no exploten) y lo que quieres es que exploten a distinto tiempo, cosa que no veo lógica.

    Lo segundo es que para hacer desaparecer un objeto progresivamente a lo largo de su recorrido tienes el modificador "Build" que hace exactamente eso, desaparecer una malla polígono a polígono en un orden.
    ¿Que como se ajusta ese orden?
    Pues seleccionando el objeto y pulsando Ctrl+F para elegir una opción.

    Además de esto, también hay otros modos de hacerlo, como por ejemplo animar una textura del canal alpha.
    "Algún día todo será digital". Caronte.
    Mi web: NicoDigital.com

  5. #5
    Acólito Blenderita Avatar de MMalkavian
    Fecha de ingreso
    Jan 2008
    Mensajes
    182

    Re: Problema con explode y pintura de peso.

    Ok.

    Muchas gracias, Caronte: Rápido y certero, como siempre :D. En cuanto llegue a casa lo pruebo y te comento.

    He tardado en escribir esto porque desde casa la línea no me enruta bien hacia el foro (ahora mismo estoy escribiendo desde la uni), no se que cuernos le pasara a la conex. Intentaré reiniciar el router y cambiar la DNS a ver si así :/ ...

    Un Saludo.
    Última edición por MMalkavian; 21-10-2008 a las 17:01

Temas similares

  1. Blender Modificador explode
    Por Freemind en el foro Blender
    Respuestas: 0
    Último mensaje: 18-05-2012, 00:26
  2. Respuestas: 2
    Último mensaje: 03-04-2010, 02:35
  3. ZBrush Problema con textura y pintura
    Por lucasv8 en el foro Materiales y Texturizado
    Respuestas: 3
    Último mensaje: 08-07-2009, 18:08
  4. Problema con el peso de una animacion en 3ds Max
    Por Arlequiin en el foro Animación y Rigging
    Respuestas: 14
    Último mensaje: 04-08-2008, 16:01
  5. Blender Explode
    Por gargarensis en el foro Plugins
    Respuestas: 18
    Último mensaje: 19-10-2006, 15:07

Actualmente estos son sus permisos de publicación en el foro.

  • -No puedes crear nuevos temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes responder temas al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes subir archivos adjuntos al no estar registrado o no haber iniciado sesión en el foro.
  • -No puedes editar tus mensajes al no estar registrado o no haber iniciado sesión en el foro.
  •