Resultados 1 al 4 de 4

Tema: Polígonos sin textura con ZBrush

  1. #1
    Usuario Senior
    Fecha de ingreso
    Feb 2005
    Mensajes
    23
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    2

    Zbrush Polígonos sin textura con ZBrush

    Hola a todos, he leído mucho este foro, pero esta es la primera vez que escribo. Estoy intentando hacer un modelo para un videojuego con Normal Maps hecho con ZBrush, creo la forma básica en 3dstudio Max 7, lo mapeo y ajusto en Unwrap, luego lo exporto a (*.obj), en este proceso puse también que se me exportasen las normales, creo que ahí está el error, con los digitos en #12, lo importo en el ZBrush y me pongo a trabajar con él, lo subdivido, le meto detalles.

    Cuando voy a hacer el Normal Map, me lo hace con multitud de agujeros, o sea, de polígonos sin rellenar, en el visor del ZBrush no veo esos huecos, pero pasado el 3ds es un desastre, empieza de 0 sin exportar las normales y me sale bien, pero me gusta mucho más el antiguo modelo que hice que además le dedique mazo de tiempo y me gustaría rescatarlo, sabéis si hay algún modo? También cuando le creo textura con el ZBrush cuando salgo del modo de proyección los polígonos anteriormente mencionados no se me texturizan.

    Creo que es porque esos polígonos no tienen bien las normales, estas se jodieron en alguna parte del proceso, el caso es que me gustaría saber si ya es un fallo irremediable y no puedo hacer nada con esa malla o si puedo repararla de algún modo.

    Aprovecho también para preguntar para qué sirve el plugin zmapper, en teoría es para hacer Normal Maps, pero ya el ZBrush lo hace por defecto por lo que no sé en qué puede ayudar, con el podría arreglar esta cagada?

  2. #2
    Maestro -YeDaY- Avatar de -YeraY-
    Fecha de ingreso
    Apr 2004
    Ubicación
    Islas Canarias
    Mensajes
    2,691
    Gracias (Dadas)
    1
    Gracias (Recibidas)
    9

    Polígonos sin textura con ZBrush

    Bueno alkalor, lo primero bienvenido al foro y ahora la respuesta. Te recomiendo que siempre que tengas una duda y sobre todo se pueda ver con una imagen, que la postes así te podremos ayudar mucho mejor, pero vamos, creo que se dónde está tu problema.

    Cuando no se rellenan los polígonos en ZBrush en el proyection master (al salir de el) y el modelo es importado de otro programa con un Unwrap que no es de ZBrush pasa el siguiente problema: ZBrush no te reconoce la superficie del polígono si este está tapado en las UVS.

    Es decir, tienes un polígono solapado o encima de otro en las UVS, tienes que mirar eso y haz una prueba.

    Si tienes ese modelo que no quieres cambiar porque te ha salido bien, en teoría hay una forma de cambiar las UVS en 3dsmax y volver al ZBrush sin tener que hacer otra vez el modelo, que es así: https://www.bobbybruceband.com/Chris/uv/fix%20uv.htm.

    De todas formas, si te vuelves muy loco, aplica un avtile en texture y que te cree el ZBrush el mapa UV y luego exporta el modelo desde ZBrush, bueno, si tienes alguna duda pregunta y si quieres pon imágenes para que los compañeros vean mejor el problema un abrazo.

  3. #3
    Usuario Senior
    Fecha de ingreso
    Feb 2005
    Mensajes
    23
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    2

    Polígonos sin textura con ZBrush

    Yo también pensé que serían polígonos solapados, cosa que me extraño ya que me tire casi una hora Unwrapeado para ponerlo todo como dios manda, aun así me entro la duda y volví a exportarlo al max y edite el Unwrap, pero este estaba bien. Ahora no puedo poner imágenes ya que el modelo tengo en otro PC, intentaré esta noche ponerlas.

    Entonces, si pongo avtile dentro del ZBrush me genera un nuevo mapeado? Rescribiendo el anterior?
    Si es así creo que será una buena manera de salvar el modelo, pero te crea un mapeado decente o la locura de triángulos que hace el ZBrush? Es que el mapeado por triángulos ese no hay quien lo edite luego en Adobe Photoshop.

  4. #4
    Maestro -YeDaY- Avatar de -YeraY-
    Fecha de ingreso
    Apr 2004
    Ubicación
    Islas Canarias
    Mensajes
    2,691
    Gracias (Dadas)
    1
    Gracias (Recibidas)
    9

    Polígonos sin textura con ZBrush

    Eso es lo malo, que el mapeado de ZBrush no es bueno, para editar, es bueno en el sentido de que si nada más que quieres practicar ea, montón de polígonos pequeños sueltos bueno, para esta vez utiliza el Avtiles y con un vratio de 1 que seguro que te ayuda a salvarlo, luego ya sabes, hacer un flip y tal.

    Y sí, es la locura de mapeado del ZBrush.

    De todas formas, prueba hacer esto alkalor: con la textura puesta ya y en ZBrush, vete a textures/fix seams, normalmente esto sirve para cuando ves que se parte la textura un poco, no sé, con la misma.

    Posdata: pero sin imágenes no te puedo ayudar mucho.

Temas similares

  1. Respuestas: 5
    : 25-05-2017, 18:35
  2. ZBrush Cómo aplicar textura en el ZBrush
    Por Jower en el foro Materiales y Texturizado
    Respuestas: 0
    : 07-07-2015, 19:24
  3. ZBrush Problema con textura y ZBrush
    Por hfgr en el foro Materiales y Texturizado
    Respuestas: 1
    : 30-05-2011, 10:38
  4. Textura por polígonos
    Por deodin en el foro Infografía General
    Respuestas: 3
    : 21-12-2009, 14:47
  5. Textura rara ZBrush a 3dsmax
    Por polterizer en el foro Materiales y Texturizado
    Respuestas: 0
    : 12-07-2008, 10:11

Etiquetas para este tema