Resultados 1 al 4 de 4

Tema: Problema novato de vértices

  1. #1
    Usuario Avanzado
    Fecha de ingreso
    Oct 2005
    Ubicación
    chile
    Mensajes
    118
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    0

    Problema noob de vertices

    La verdad es que, a esta altura ya debería saber solucionar esto, pero aun no puedo. Estoy modelando una lámpara de escritorio, bueno, voy en la base recién, la estoy modelando extruyendo planos y Simetry, pero al llegar a la parte de la punta, tengo que juntar de algún modo todos los vértices, así que, aplique collapse y se juntaron, pero quedaron solo polígonos de tres lados y la Maya se ve horrible al suavizarla.

    Aquí dejo una fotografía de cómo se ve sin solucionar el problema, una después de la solución y cómo se ve con MeshSmooth.

    Como puedo solucionar esto?
    Por favor ojalá me ayuden, esto ya me ha pasado varias veces.

    Vaya, casi me olvido, estoy trabajando con 3dsMax 8, aunque por le fotografía es evidente, pero aun así.
    Miniaturas adjuntas Miniaturas adjuntas -pifia-3.jpg   -pifia.jpg   -pifia-2.jpg  
    Última edición por Lesak; 26-05-2007 a las 02:34

  2. #2
    XSI Evangelist! Avatar de edward_alderete
    Fecha de ingreso
    May 2006
    Ubicación
    Lima - Perú
    Mensajes
    330
    Gracias (Dadas)
    5
    Gracias (Recibidas)
    22

    Problema noob de vertices

    Hola lesak:
    En realidad, los polys triangulares no son un problema y en muchos casos son necesarios. Por ejemplo, en esta imagen tienes un modelos parecidos al tuyo, es una semiesfera estirada, son iguales, sólo que uno te muestra la malla que la conforma.

    Los extremos tiene muchas caras triangulares, que al aplicarle TurboSmooth se suavizan sin deformación de la malla en el render.

    Y por que en tu modelo sí se deforma? Dando vuelta a los objetos descubrimos que no hay geometría más, allá del borde (observa que los vértices polémicos conforman el borde y además el borde es coplanar).

    Ahora bien, tu geometría es similar al de la siguiente imagen, y al aplicarle el TurboSmooth sí hay deformación, porque en esencia TurboSmooth busca generar continuidad en la geometría es decir busca redondear toda la malla interpolando polys. Son como cuerdas tirando de los vértices. Por eso se forma una depresión hacia el lado donde hay más segmentos.

    La solución consiste en decirle a TurboSmooth que redondear y que no.

    Una técnica antigua era seleccionar aquellos segmentos (en el Editable Poly) que no querías que suavice y le cambiabas el valor crease desde 0.0 (redondeado) hasta 1.0 (sin redondeo). La desventaja es que, si modificas tu malla agregando o quitando geometría estos valores se pierden o se desconfigura el suavizado. En la imagen he aplicado el valor 1 a los segmentos destacados en rojo.

    La forma más práctica (a mí entender) es que, apliques grupos de suavizado a tu malla antes de aplicar TurboSmooth. Esto logras de 2 maneras:
    • a. Aplicando al Editable Poly un modificador smooth. Basta con darle click al botón autosmooth (el ángulo entre 30 y 45).
    • b. O sino en el mismo Editable Poly, seleccionar todos los polys y aplicarle autosmooth (busca en la persiana polygon properties).
    • una vez hecho esto en el modificador TurboSmooth activamos la casilla sepárate by: smoothing groups. Ubicada en el grupo surface parameters.

    Si me has entendido, espero que te sirva de ayuda. Es lo que yo te recomiendo.
    saludos.

    Posdata 1: una aplicación excelente de la modificación del parámetro crease lo encuentras en el tutorial de Juana de Arco, en el modelado de la espada.

    Postdata 2: lo que hacen los grupos de suavizado es asignar números a los polys en función al ángulo que forman dos a dos. Estos números se usan durante el render para crear una apariencia de suavizado.
    Miniaturas adjuntas Miniaturas adjuntas -3dpoder_20070525_dudas_mallas_01.jpg   -3dpoder_20070525_dudas_mallas_02.jpg   -3dpoder_20070525_dudas_mallas_03.jpg   -3dpoder_20070525_dudas_mallas_04.jpg   -3dpoder_20070525_dudas_mallas_05.jpg  

    En la vida hay que intentar muchas cosas, aunque algunas nos salgan bien. - M. A. Cornejo
    Mi tuto de Modelado. - .Starcraft 2: Templario tétrico (WIP). - .Simulaciones XSI. - .I Love XSI


  3. #3
    Usuario Avanzado
    Fecha de ingreso
    Oct 2005
    Ubicación
    chile
    Mensajes
    118
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    0

    Problema noob de vertices

    Edward_alderete me has hecho un verdadero tutorial, no solo dándome una respuesta, sino explicándome paso a paso la causa del problema y soluciones.

    Las palabras son pocas para poder agradecer tu ayuda. Muchas gracias.

    Aportes como este alegran el día.

  4. #4
    XSI Evangelist! Avatar de edward_alderete
    Fecha de ingreso
    May 2006
    Ubicación
    Lima - Perú
    Mensajes
    330
    Gracias (Dadas)
    5
    Gracias (Recibidas)
    22

    Problema noob de vertices

    Fue un gusto.
    saludos .
    En la vida hay que intentar muchas cosas, aunque algunas nos salgan bien. - M. A. Cornejo
    Mi tuto de Modelado. - .Starcraft 2: Templario tétrico (WIP). - .Simulaciones XSI. - .I Love XSI


Temas similares

  1. Problema con los vértices
    Por yaka_1989 en el foro Animación y Rigging
    Respuestas: 0
    : 29-12-2016, 05:18
  2. Blender Problema con los vértices
    Por Exirens en el foro Modelado
    Respuestas: 9
    : 26-04-2011, 22:53
  3. Problema con vértices
    Por ManuH en el foro Modelado
    Respuestas: 1
    : 04-03-2011, 22:57
  4. Problema con vértices
    Por titan903 en el foro Modelado
    Respuestas: 2
    : 12-10-2009, 18:59
  5. Problema con vértices
    Por Xtreme637 en el foro Modelado
    Respuestas: 11
    : 09-01-2005, 01:27