Resultados 1 al 12 de 12

Tema: Error en el suavizado de polígonos

  1. #1
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Error en el suavizado de polígonos

    Hola. Tengo un error en 3ds Max 2011 en el suavizado de un elemento. En este caso en particular es un ojo (pero me paso también en otro modelado.) que lo tengo que trabajar. Es exportado de otro programa (no sé cuál.) en un (*.obj), quizás aquí está el problema.

    El tema es que, al aplicar el modificador TurboSmooth se me suaviza la forma, pero no al 100%. No lo hace bien en la zona de las aristas.

    Si le subo el valor del TurboSmooth el error no se va.

    Adjunto imágenes para que se entienda mejor.

    -imagen-error-01.jpg
    -imagen-error-02.jpg
    -imagen-error-03.jpg

    Si alguien sabe alguna solución se la agradecería mucho. Gracias.
    Última edición por teblopa; 13-01-2012 a las 23:13

  2. #2
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950
    Gracias (Dadas)
    147
    Gracias (Recibidas)
    182

    Error en el suavizado de polígonos

    Eso ocurre porque justo donde se marcan esas aristas hay más de un edge. Compruébalo. Saludos.

  3. #3
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Limon 3DPoder Error en el suavizado de polígonos

    Reihzard, muchas gracias por escribir. Pero lamentablemente no, no hay varios Edges. Adjunto dos imágenes de cuando seleccione un Edge y lo moví de lugar.

    -imagen-error-04.jpg
    -imagen-error-05.jpg

    Se les ocurre otra posible solución? Muchas gracias.

  4. #4
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950
    Gracias (Dadas)
    147
    Gracias (Recibidas)
    182

    Error en el suavizado de polígonos

    ¿Puedes subir ese (*.obj) para ver que ocurre? De todas formas, ese ojo no es nada complejo de hacer. Supongo que igual lo has utilizado por la textura del iris, pero mapear eso tampoco tiene complicación alguna. Saludos.

  5. #5
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Error en el suavizado de polígonos

    Reihzard. Gracias por interesarte. Mira este error me pasa también en una forma más compleja (en un pelo de un personaje).

    Subí el error en el ojo para que se vea mejor. El ojo lo hago de nuevo, con el pelo se me complica.

    Subo el archivo max y un obj.

    Fíjate a ver si ves algo extraño.

    Muchas gracias.
    Archivos adjuntados Archivos adjuntados

  6. #6
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950
    Gracias (Dadas)
    147
    Gracias (Recibidas)
    182

    Error en el suavizado de polígonos

    Pues no veo nada raro, ni en el objeto ni en el render. A mí no me aparecen esas aristas que has puesto en las imágenes. Solo he podido abrir el (*.obj) ya que solo trabajo con max2009.

    De todas formas, te envío un archivo (*.max) con 3 ojos: el de la izquierda sin smooth, el del medio con Smooth a 1, y el de la derecha con 2, a ver si sigues viendo ese problema. Saludos.
    Archivos adjuntados Archivos adjuntados

  7. #7
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Error en el suavizado de polígonos

    Reihzard. Mira, abrí el tu obj y lo veo perfecto. Abro mi obj (el que adjunte al foro) y lo veo con el mismo error (es más, creo que se ve peor).

    Te adjunto la imagen:
    -imagen-error-06.jpg

    Tendré algún error de seteo/visualización en el 3ds Max 2012?
    El problema es que es un error difícil de buscar en la red. Muchas gracias por tu ayuda.

  8. #8
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950
    Gracias (Dadas)
    147
    Gracias (Recibidas)
    182

    Error en el suavizado de polígonos

    Pues tiene toda a pinta de ser un problema de max 2012. Prueba a utiliar el ojo del archivo que te he pasado, lo seteas igual y le añades los materiales del ojo malo y ya está. Saludos.

  9. #9
    Usuario Senior Avatar de JLM
    Fecha de ingreso
    Feb 2007
    Ubicación
    León
    Mensajes
    51
    Gracias (Dadas)
    7
    Gracias (Recibidas)
    7

    Error en el suavizado de polígonos

    Hola. Yo que ando también trasteando con el 3ds Max 2012 pero el design en mi caso, he tenido veces en que al importar.obj, me ha pasado lo mismo. Lo que he hecho ha sido utilizar la opción auto Smooth a 30.0, en vez de aceptar import from file, esto combinado con un TurboSmooth a 1 iteración es más que suficiente en la mayoría de los casos. Un saludo.
    Miniaturas adjuntas Miniaturas adjuntas -prueba.jpg  

  10. Gracias teblopa Agradece este post
  11. #10
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Error en el suavizado de polígonos

    Reihzard. Hay algo que se rompe al importar los obj del modelo que tengo que usar al 3ds Max 2011 (es la versión que uso, me equivocó en la versión que dije más arriba).

    Acabo de comprobar que todas las partes que me pasaron del modelo en obj tienen este problema.

    Adjunto dos imágenes de las manos.

    La primera es el (*.obj) que me dieron, que es un High Poly sin el TurboSmooth.

    -mano-error-01.jpg

    La segunda es cuando le aplico TurboSmooth, ahí se ve el error. (no me equivocó al subir las imágenes).

    -mano-error-02.jpg

    En esta parte del cuerpo la puedo usar sin el suavizado, pero hay otras que no, que necesito usar el TurboSmooth si o si.

    Tendria que importar nuevamente los obj en otra versión de 3ds a ver si es eso.

    Veo de probarlo a ver qué pasa.

    Si a alguien se le ocurre otra posible solución, será bienvenida.

    Reihzard, muchas gracias por tu tiempo.

  12. #11
    Road to nowhere Avatar de Reihzard
    Fecha de ingreso
    Apr 2010
    Ubicación
    CyL
    Mensajes
    950
    Gracias (Dadas)
    147
    Gracias (Recibidas)
    182

    Error en el suavizado de polígonos

    De nada. Sé que puede parecer una chorrada, pero has probado la opción use Nurms subdivisión de Editable Poly, sin usar el TurboSmooth?
    Y probando con el MeshSmooth en vez de TurboSmooth?
    Prueba a ver si te da ese problema de esas dos formas, un saludo.

  13. Gracias teblopa Agradece este post
  14. #12
    Usuario Novato
    Fecha de ingreso
    Jan 2012
    Mensajes
    12
    Gracias (Dadas)
    4
    Gracias (Recibidas)
    1

    Error en el suavizado de polígonos

    Jlm. Perdón, o no se actualizo tu mensaje o me lo pase por alto. Mucha gracias por tu respuesta. Era eso nada más, tenías razón.

    Entendi el problema. El error estaba al importar el (*.obj) en el 3ds Max, más precisamente con las oipciones de normals.

    En el cuadro de opciones al importar un obj hay un apartado de normals, adjunto una captura:
    -import-obj.jpg

    Yo lo tenía tildado en la opción import from file y es ahí donde me generaba ese error extraño en los vértices de los objetos.

    Cuando lo cambie a Faceted, me lo importo facetado y al agregar el modificador turbosmoth se suavizo sin problemas.

    Espero que este mensaje le sirva a alguien que se encuentre con este mismo problema.

    Reihzard y jlm, muchas gracias por sus ayuda.

    Abrazo.
    Última edición por teblopa; 19-01-2012 a las 04:00

  15. Gracias Murtzia Agradece este post

Temas similares

  1. Maya Suavizado
    Por DUZGO en el foro Modelado
    Respuestas: 9
    : 20-02-2009, 16:17
  2. Suavizado
    Por dixan en el foro Modelado
    Respuestas: 4
    : 19-05-2006, 20:02
  3. Suavizado
    Por Thule en el foro Problemas con Programas
    Respuestas: 1
    : 24-12-2004, 22:01
  4. Error al subdividir polígonos
    Por Fangface en el foro Modelado
    Respuestas: 3
    : 03-11-2004, 17:27
  5. Suavizado
    Por andy_00 en el foro Modelado
    Respuestas: 2
    : 01-12-2003, 20:22