Resultados 1 al 8 de 8

Tema: Problema al hacer baking de mis modelos

  1. #1
    Usuario Novato
    Fecha de ingreso
    Aug 2019
    Ubicación
    Linares
    Mensajes
    12
    Gracias (Dadas)
    8
    Gracias (Recibidas)
    0

    Problema al hacer baking de mis modelos

    Saludos a todos. Llevo tiempo practicando el modelado en ZBrush de cabezas para mejorar la anatomía facial y crear mis propios modelos con su consiguiente retopología en 3ds Max tal y como me enseñaron.

    El problema es que al pasar el modelo Low a Substance Painter y hacer baking para extraer los detalles del modelo de high, bakea casi todo bien, excepto que la malla de Low poly se queda marcada en el modelo bakeado final y algunos defectos que le salen que no se como solucionar. Me pasa en todos los modelos medianamente complejos que hago en ZBrush con su retopología y ya no sé si es fallo de la retopo o del modelo de alta.

    En este caso son los polígonos extraños que le salen, la lengua sale horrible y todo lo erróneo que se puede ver en las imágenes.

    Muestro mis capturas. Gracias de antemano.
    Miniaturas adjuntas Miniaturas adjuntas Problema al hacer baking de mis modelos-1.jpg   Problema al hacer baking de mis modelos-2.jpg   Problema al hacer baking de mis modelos-3.jpg  

  2. #2
    Usuario completo
    Fecha de ingreso
    May 2016
    Ubicación
    Valencia
    Mensajes
    202
    Gracias (Dadas)
    38
    Gracias (Recibidas)
    63

    Problema al hacer baking de mis modelos

    Puedes mostrar las UV del modelo low?

  3. #3
    Usuario Novato
    Fecha de ingreso
    Aug 2019
    Ubicación
    Linares
    Mensajes
    12
    Gracias (Dadas)
    8
    Gracias (Recibidas)
    0

    Problema al hacer baking de mis modelos

    Cita Iniciado por Lluc21 Ver mensaje
    Puedes mostrar las UV del modelo low?
    Sé que no hay que hacer cortes por mitad de la cara, pero no consigo hacerlo como me explicaron en clase, con los mínimos cortes y por detrás, ya que acaban generando overlap (creo que se llama así cuando se montan las UV unas a otras si no me equivoco) así que está es la forma que decidí hacerlo
    Miniaturas adjuntas Miniaturas adjuntas Problema al hacer baking de mis modelos-vampire-uvw.png  

  4. #4
    Usuario completo
    Fecha de ingreso
    May 2016
    Ubicación
    Valencia
    Mensajes
    202
    Gracias (Dadas)
    38
    Gracias (Recibidas)
    63

    Problema al hacer baking de mis modelos

    Cita Iniciado por Drilent Ver mensaje
    Sé que no hay que hacer cortes por mitad de la cara, pero no consigo hacerlo como me explicaron en clase, con los mínimos cortes y por detrás, ya que acaban generando overlap (creo que se llama así cuando se montan las UV unas a otras si no me equivoco) así que está es la forma que decidí hacerlo.
    Una cosa que tienes que tener en cuenta al hacer bakes es que el modelo Low Poly tenga los edges que sean UV seam (los edges que hacen borde en el UV) marcados como sHarp Edge en el modelo, y todo lo demás en soft. Luego en Substance te recomiendo hacer el bake de normales al menos el doble de grande del tamaño que vayas a sacar de textura. El problema de la lengua tiene toda la pinta de ser que la distancia frontal y trasera (a la hora de hacer el bake en Substance) son demasiado grandes y cuando intenta sacar las caras superiores atraviesa y hace el bake del otro lado.

  5. Gracias Drilent Agradece este post
  6. #5
    Usuario completo
    Fecha de ingreso
    Jul 2004
    Mensajes
    270
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    63

    Problema al hacer baking de mis modelos

    Parece que tienes problmas con algunos polígonos qu eno están soldados en el Low Poly, de todos modos prueba lo siguiene: en max selecciona todas las caras del objeto, en smoothing groups dale a clear y a autosmooth, esto debería solucionar gran parte del problema, en caso de que quede algo, si realmente están los polígonos sin unir, tendras que soldar los vretices a mano y repetir el proceso, pero ya que trabajas con ZBrush te recomendaria seguir el proceso inverso, crea el low en max, pasalo a ZBrush y añade detalle haciendo subdivisiones, crea las UVS en ZBrush, ya que da unos resultados excelentes y exporta el Low Poly y el High Poly por separado, también tiene la funcion de cap holes que podría solucionarte el problema de los polígonos separados, aunque quizas te complique más, dependiendo de cómo tengas la malla, pruebalo y me cuentas.

  7. Gracias Drilent Agradece este post
  8. #6
    Usuario Novato
    Fecha de ingreso
    Aug 2019
    Ubicación
    Linares
    Mensajes
    12
    Gracias (Dadas)
    8
    Gracias (Recibidas)
    0

    Problema al hacer baking de mis modelos

    Muchas gracias por vuestros aportes, voy a probar esas posibles soluciones y a ver si soluciono un par de modelos que tengo con estos problemas ya que esto solo me pasa con modelado orgánico.
    Saludos

  9. #7
    Usuario Novato
    Fecha de ingreso
    Aug 2019
    Ubicación
    Linares
    Mensajes
    12
    Gracias (Dadas)
    8
    Gracias (Recibidas)
    0

    Problema al hacer baking de mis modelos

    Cita Iniciado por natros Ver mensaje
    parece que tienes problmas con algunos polígonos qu eno están soldados en el Low Poly, de todos modos prueba lo siguiene: en max selecciona todas las caras del objeto, en smoothing groups dale a clear y a autosmooth, esto debería solucionar gran parte del problema, en caso de que quede algo, si realmente están los polígonos sin unir, tendras que soldar los vretices a mano y repetir el proceso, pero ya que trabajas con ZBrush te recomendaria seguir el proceso inverso, crea el low en max, pasalo a ZBrush y añade detalle haciendo subdivisiones, crea las UVS en ZBrush, ya que da unos resultados excelentes y exporta el Low Poly y el High Poly por separado, también tiene la funcion de cap holes que podría solucionarte el problema de los polígonos separados, aunque quizas te complique más, dependiendo de cómo tengas la malla, pruebalo y me cuentas.
    He hecho el mapeado por medio de ZBrush como dijiste y ha mejorado mucho, a pesar que mi profesor me prohibió hacer las UV en ZBrush porque el resultado de las UV no es nada profesional, para este caso me interesa terminar el modelo con una calidad aceptable y subirlo al portfolio.
    Ahora el problema es que para texturizarlo en Substance painter, he perdido la selección por materiales que tenía de 3ds Max para poder pintar: ojos, dientes y lengua de forma independientes. La pregunta es: ¿Se pueden consevar las seleccion por materiales en ZBrush que trae de 3ds max? Tal cual está se puede texturizar, pero sin seleccion por materiales se puede hacer muy tedioso sin el apoyo de la seleccion por partes.
    Gracias de antemano
    Miniaturas adjuntas Miniaturas adjuntas Problema al hacer baking de mis modelos-mejora1.jpg  

  10. #8
    Usuario completo
    Fecha de ingreso
    Jul 2004
    Mensajes
    270
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    63

    Problema al hacer baking de mis modelos

    Si haces las uvs en ZBrush se va a olvidar de los ajustes de max, lo mejor que puedes hacer, si estas en un curso, es forzarte a solucionar los errores a mano, no siempe vas a tener tiempo de recurrir a un foro y esperar la respuesta, por lo que deberías hacer mucho ensayo y error, no recurrir a herramientas así, hablamos del proceso de aprendizaje, a la hora de trabajar vas a buscar lo más rapido y que mejores resultados de, pero no siempre vas a tenre esa herramienta, además de que si es para un trabajo evidentemente el profesor va a ver que has usado ZBrush con solo mirar las UVS.
    imagino que cuando hablas de materiales te refieres a multi materiales, pero vamos, vuelves a max con esas uvs, lo conviertes en Edit Poly, haces las ids y editas las uvs, que tendran el aspecto de ZBrush solo tendras que reordenarlas, no obstante lo dicho, deberías solucionarlo por tu cuenta, porque ahora mismo se te ha planteado un problema, lo has resuelto, pero no tienes ni idea de como.

  11. Gracias Drilent Agradece este post

Temas similares

  1. 3ds Max Problema con tamaños al importar (Baking en Marmoset)
    Por Ganimedes en el foro Problemas con Programas
    Respuestas: 0
    : 25-06-2020, 23:05
  2. Respuestas: 1
    : 30-03-2017, 21:29
  3. Problema al hacer el baking del normal con Xnormal
    Por Quads en el foro Materiales y Texturizado
    Respuestas: 0
    : 30-08-2016, 23:06
  4. Blender Cómo hacer modelos estilo minecraft en Blender
    Por krdozo en el foro Modelado
    Respuestas: 5
    : 25-04-2013, 07:08
  5. Cómo hacer modelos menos toscos
    Por devnul en el foro Modelado
    Respuestas: 95
    : 03-08-2005, 16:43