Página 1 de 2 12 ÚltimoÚltimo
Resultados 1 al 15 de 18

Tema: Problema al bumpear una textura y con mapas especiales

  1. #1
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Question Problema al bumpear una textura y con mapas especiales

    Bueno ya he terminado el modelo y las texturas, pero tengo un problema al hacer las normales, como veis en la imagen la luz que enfoca se aplica de forma distinta dependiendo de cada pieza del modelo. ¿hay alguna forma de arreglarlo y que se vea homogéneo? La luz afecta bien a la superficie, pilla la profundidad y tal, pero ahí no, no sé porque hace eso, de hecho, el brazo y el pecho son casi del mismo color.

    Además, me gustaría hacer un mapa de reflection y de Ambient Occlusion, ya he hecho el Specular. ¿alguien sabe cómo se hace? Gracias por la ayuda.
    Miniaturas adjuntas Miniaturas adjuntas Problema al bumpear una textura y con mapas especiales-prueba-5.png  
    Última edición por Amnoon; 28-09-2012 a las 03:48

  2. #2
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    ¿Si renderizas la imagen sin el Normal Map, esas diferencias de color no aparecen? Prueba de hacer un render sin las texturas de color, sólo el Normal Map, ahí vas a poder apreciar bien de qué manera influye el nmap.
    ¿Cómo generaste el nmap? Me resulta extraño que todas las parten tengan un borde cómo si cada región tuviese volumen propio. Eso es lo que te está causando problemas creo. Es como que cada pieza tuviese un Bump, pero en las costuras esa altura varía de manera que, se ve distinto a la luz.

    Lo bordes deberían verse sólo donde la geometría tiene volumen, si las manos, brazos y cuerpo, por ejemplo, tienen una superficie uniforme sin variación de altura entre ellas, esas piezas no deberían distinguirse mucho del color de fondo de la imagen (Normal Map), resaltarían sólo las uñas y los ojos, por ejemplo.

    Reflection map, creo que no ataña al modelo sino al entorno. Donde el objecto es más o menos reflectivo lo regulas con el Specular map que ya hiciste.

    Ambient Occlusion: ¿Qué render estas utilizando? Una opción simple es generar un material AO y forzar en el render que use ese material (dependiendo del render) y ahí generas un rendertotexture.

    Espero que te sirva.

    Esteban.

  3. #3
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    Lo he hecho con PixPlant, aunque con Xnormal también pasa. No, sin el Bump, no aparecen esas diferencias. Pensé en que la rotación de la zona del pecho influye, es decir los brazos están colocados de forma horizontal y el pecho vertical, y eso puede influir a como le da la luz, pero no estoy seguro. Yo solo género el normal de la textura, no uso el modelo.
    ¿Cómo podría hacerlo para que no apareciesen esos bordes que tú dices? ¿con otro programa?
    El reflection creo que se cómo hacerlo, pero el ambient, debería aplicarle el Bump al modelo para que guarde los pliegues y esas cosas de la textura, y luego el render to texture?

  4. #4
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    Una cosa que puedes probar es con Photoshop retocar los bordes, de manera que, desaparezcan. (el mismo color del fondo) y luego volver a convertir la imagen en Normal Map. https://developer.Nvidia.com/content/...dobe-Photoshop. https://www.youtube.com/watch?v=kg3ptxgzdsi.

    No sé que tanta diferencia va a haber de un programa a otro. https://www.CrazyBump.com/.

    Porque se me hace que la imagen con la textura tiene el fondo (fuera de las piezas del modelo) de un color completamente distinto, de manera que, cuando generas el nmap el programa cree que el fondo tiene otra elevación y ahí es cuando suergen esos cantos en las costuras.

    El AO no lo vas a poder generar de esa manera ya que los bumps no hacen modificaciones en la geometría, sólo se ven si hay luces en la escena, y al generar Ambient Occlusion las luces se ignoran. De manera que la rugosidad no la vas a ver. Sólo si fuera un displace map.

    Ya que no tienes un objeto en High Poly, ese AO que quieres (con los detalles de la textura) no lo vas a poder hacer.

    Pero podrías trucarlo un poco.
    1_desactivar la textura del modelo, solo darle un color blanco o gris y sólo dejar el Normal Map activado. (para que se vean los bumps) subile el valor exagerando para que los bumps sean bien definidos.
    2_apagar las luces directas de la escena y sólo dejar global illumination activo, de manera de no tener sombras directas sino más bien ambientales.
    3_poner el modelo en el centro de la escena con un plano que le sirva de piso. El piso debe ser de color claro, aunque los vas a tener que regular para obtener luminosidad necesaria.
    4_renderizar y hacer los ajustes necesarios de luz.
    4_ hacer un rendertotexture completemap.

    De esa manera vas a obtener una textura blanca o clara con solo detalles del nmap.

    No es lo mejor, pero puede funcionar.

  5. Gracias Amnoon Agradece este post
  6. #5
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    Pues probaré con los tutoriales que me has pasado a ver. Adjunto la textura. ¿ocurre el error ese que comentas?
    Miniaturas adjuntas Miniaturas adjuntas Problema al bumpear una textura y con mapas especiales-texturemap.jpg  

  7. #6
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    Si, fíjate el contraste que hay entre el color de la piel (bien claro) y el fondo. Cuando generas un Normal Map, las rugosidades se obtienen da una escala de grises o de tonos, como es en tu caso.

    La zonas claras se van a traducir en el modelo en zonas más elevadas (o al revés, no me acuerdo). Si miras tu nmap, vas a ver qué esa costura bien marcada se produce en las zonas de la piel, porque el programa piensa que esa zona (al ser más clara que el fondo) representa una elevación.

    Para evitar esto tienes que extender las zonas un poco más afuera del Unwrap. Nunca es conveniente que las zonas de la textura terminen justo (o con poco margen) de dónde están los patchs del Unwrap. De esta manera si bien esa costura la vas a tener lo mismo, pero por lo menos va a estar fuera de la zona visible de la textura.

    Espero que se entienda lo que escribí.
    Última edición por estebang; 28-09-2012 a las 15:04

  8. #7
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    https://www.youtube.com/watch?v=p4p23...eature=related. Fíjate en el minuto 4:48 a lo que me refiero de extender las zonas.

  9. #8
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    A ok pues probaré. Tiene pinta de ser eso.

  10. #9
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    Pues no, sigue pasando, hasta normalizando las zonas en Adobe Photoshop ni expandiendolas.

  11. #10
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    Raro, raro, eso pasa sólo en los viewports o si haces un render también. Subí la imagen de cómo quedo ahora el Normal Map.

  12. #11
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    Vale, el principal problema es que el busto esta girado en la textura mientras el cuerpo en forma horizontal, parece que eso hace que la luz afecte al modelo de forma distinta. Si no logro solucionarlo, subiré el render con el mapa actualizado (con el nuevo UV) y el mapa en cuestión.

  13. #12
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    He hecho una prueba rápida (y a lo rudo), volteando el busto y expandiendo la textura y homogeneizandola. Sin Bump se ve bien, las zonas demasiado bruscas de color es por el tono de piel usado pues lo he hecho rápido para ver cómo queda. He sacado las normales de eso con PixPlant y pasa lo mismo tanto en el render como en el viewport (con creazybump también pasa). Lo único que queda, es que lo normal es que pasen esas cosas y yo he cortado por zonas demasiado visibles.

    De hecho, hasta coviertiendo todo el mapa de normales solo con un color, que no debería afectar nada a la superficie hace lo mismo. Eso sí que es extraño.
    Miniaturas adjuntas Miniaturas adjuntas Problema al bumpear una textura y con mapas especiales-prueba-6.png  
    Última edición por Amnoon; 28-09-2012 a las 20:26

  14. #13
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    Lo que te puede aconsejar ahora a la apuradas, es lo que dije de Photoshop. Importa el nmap en Adobe Photoshop, retoca la imagen de manera que, el color del fondo y el color de dónde está la piel sea uno solo. Es decir, borra los bordes, de manera que, lo único que se vea en la imagen sean sólo las cosas que quieres resaltar.

    Después exporta la imagen desde Photoshop como dds nmap. Fíjate el enlace del primer video que publiqué.

    Por ahora no se me ocurre nada más.

  15. #14
    Usuario Senior
    Fecha de ingreso
    Oct 2011
    Mensajes
    26
    Gracias (Dadas)
    2
    Gracias (Recibidas)
    0

    Problema al bumpear una textura y con mapas especiales

    Si, eso lo he probado si de hecho, hasta aplicando este mapa de un solo color pasa lo mismo. Cosa que no le veo yo el sentido por ningún lado.
    Miniaturas adjuntas Miniaturas adjuntas Problema al bumpear una textura y con mapas especiales-texturemap.jpg  

  16. #15
    Usuario Avanzado
    Fecha de ingreso
    Jan 2011
    Ubicación
    Hamburgo, Alemania
    Mensajes
    115
    Gracias (Dadas)
    0
    Gracias (Recibidas)
    31

    Problema al bumpear una textura y con mapas especiales

    Que material estas usando? Que render? Standard->Bump->Normal Bump->bitmap. Si quieres subí el modelo y miro a ver si encurntro algo inusual. O si no deseas por razones personales, por lo menos una parte del modelo que incluya disteintas piezas, brazo y parte del pecho.

Página 1 de 2 12 ÚltimoÚltimo

Temas similares

  1. Problema mapas
    Por fer_kapo92 en el foro Materiales y Texturizado
    Respuestas: 1
    : 28-04-2014, 23:14
  2. ZBrush Problema mapas
    Por Pol Gaskon en el foro Materiales y Texturizado
    Respuestas: 1
    : 25-10-2012, 17:21
  3. Respuestas: 5
    : 23-09-2012, 02:10
  4. Problema con mapas UV
    Por Zekemeout en el foro Materiales y Texturizado
    Respuestas: 0
    : 14-09-2009, 20:12
  5. Hacer mapas de textura
    Por Turriano en el foro Materiales y Texturizado
    Respuestas: 12
    : 12-12-2006, 19:02

Etiquetas para este tema